LLVM crash with OpenGL ES program

Discussion in 'iOS Programming' started by xytor, Apr 16, 2011.

  1. xytor macrumors newbie

    Apr 16, 2011
    Hi, I just got my first apple product (a macbook pro) a few days ago. I bought XCode 4 from the appstore, installed it and created a new OpenGL ES project.

    After a few frames of running with no code modifications from me, the program crashed with LLVM ERROR: Cannot yet select...

    So, after trying various things, the project crashes in the same way regardless of the XCode version (tried XCode 3 also) and regardless of the iPhone or iPad version.

    I don't have access to the developer forums because I didn't pay the $99 to be a paid developer.

    Does anybody have any ideas on what I should try next?

  2. PhoneyDeveloper macrumors 68040


    Sep 2, 2008
    You might want to change the compiler to LLVM GCC 4.2 or GCC 4.2. There have been some problems reported with LLVM.

    If that doesn't help you need to post a better description of the crash.
  3. xytor thread starter macrumors newbie

    Apr 16, 2011
    Since I have very little Mac experience, I may be doing this wrong. After creating the OpenGL ES project, I went to Build Settings, scrolled to Compiler version, clicked and changed it from LLVM GCC 4.2 to GCC 4.2. There's no "ok" or "accept" button so I assume just selecting it will change the settings.

    Anyway, after clicking the run button, It still crashed with this error:


    Note: It's too long so I had to use pastebin.
  4. PhoneyDeveloper macrumors 68040


    Sep 2, 2008
    I haven't seen that kind of output before but I haven't been using LLVM. I believe that it's essentially an internal compiler error. There's something about your source code that it can't compile and has caused it to give up.

    You haven't successfully changed the compiler since you're still seeing this error. There are two places that the compiler can be set, at the target level and at the project level. If you set it differently in both places the target level setting will be used. In most cases you don't want to set it at the target level and only set it at the project level.




  5. xytor thread starter macrumors newbie

    Apr 16, 2011
    None of those suggestions work. No matter what I do, I still get that error. Like I said.
    It happenes with XCode 3, XCode 4, all compilers that I can choose, all iOS versions, etc.
    I'm starting to think that they put some hardware in the new macbooks that they didn't test and isn't compatible with OpenGL ES.

Share This Page