Loads of iMac G5 problems

Discussion in 'PowerPC Macs' started by thinkmark, Jan 13, 2009.

  1. thinkmark macrumors newbie

    Joined:
    Sep 30, 2008
    #1
    Okay, so I bought 2 crap iMac's off eBay, 1 is the lowest iMac G5 ever made, the otherr is the highest. I the lower shows the 2 green LEDS and no signal for the display. The second is the same. I have given them their respectivly correct memory, clean and hoovered the insides, tried on multiple occasions to clear the Pram, and reset SMU, on both using my Alu apple keyboad. I have put a 250gb he in them , and although it is still an so drive, I just wanna see some screen .

    The higher iMac is also make very loud fan noise, while the smaller has no fan action at all.

    What can I do tiger them working again??!!

    Mark
     
  2. Passive101 macrumors regular

    Joined:
    Dec 5, 2008
    #2
    Good luck. You are basically working on a notebook.

    Did you know they were non working when you purchased them?
     
  3. thinkmark thread starter macrumors newbie

    Joined:
    Sep 30, 2008
    #3
    Well, they work, it's the display, it won't come on . Yes I knew they had problems when I bought them...

    I need the display to work. Then the rest can follow,
     
  4. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #4
    I don't think your issue is with tiger but with the machine. It sounds like the video is dead.
     
  5. thinkmark thread starter macrumors newbie

    Joined:
    Sep 30, 2008
  6. thinkmark thread starter macrumors newbie

    Joined:
    Sep 30, 2008
    #6
    Looked into it, and still nothing works. Tried everything!!

    What could i do now, other than bin them?
     
  7. Shawn D macrumors regular

    Joined:
    Dec 26, 2008
    #7
    Send them my way? ;) But your best bet is selling them on ebay for parts.. To me it sounds like they have a bad logic board and those can be pricey.
     

Share This Page