Local Server only - SLS setup question (new user)

Discussion in 'Mac OS X Server, Xserve, and Networking' started by pprior, Nov 15, 2009.

  1. pprior macrumors 65816

    Joined:
    Aug 1, 2007
    #1
    I just got SLS yesterday, trying to get initial setup going.

    My goal: local network services only (no web server, no FTP, no mail server or any other such external web/WAN). I basically want to have a centralized time machine backup and shared calendaring.

    The issue I'm having so far is that I think I've got some sort of DNS issue going on - my server zone name is cpe-zz-zzz-zzz-zzz.columbus.res.rr.com (where RR is my ISP), but I'm trying to use Server.local as my address for connection. I don't want any web access to my server, so I'm not sure why I'm not just seeing an IP here.

    My ical connection from another LAN attached computer rejects with message "The connection to the server cpe-xx-xxx-xxx-xxx.columbus.res.rr.com was refused." A different computer (laptop) strangely will connect via ical but lists the calendar also as the ...rr.com instead of Server name.

    services listed as running include: Address book, AFP, DNS, ical, ichat, open directory, Push Notification, SMB

    I can connect using finder from my mac pro, and see attached disks and time machine is backing up to it.
     
  2. TheCoupe macrumors member

    Joined:
    Mar 4, 2009
    Location:
    Northern Ireland
    #2
    first off... is the dns address of the server under 'System Preferences -> Networking' the same as your servers IP address? and are you using your servers IP address as the DNS for your client machines?

    If not... it is extremely unlikely that you will be able to get dns to function properly
     
  3. pprior thread starter macrumors 65816

    Joined:
    Aug 1, 2007
    #3
    (local) network preferences: IP address 10.0.1.23 (local address)

    Server admin: Settings/network: IP Address 10.0.1.12 but DNS Name says cpe-xx-xxx-xxx-xxx.columbus (can't read the rest).

    Is that what you mean?
     
  4. blacka4 macrumors 6502

    Joined:
    Sep 28, 2009
    Location:
    Pittsburgh
    #4
    you should probably turn off DNS on SLS. Might also want to turn off DHCP and use the airport extreame or other router to preform DHCP/DNS functions. Might help cure the problem you are having. Seems to me that you have conflicting DNS services going on and neither one can figure out what you want to do
     
  5. pprior thread starter macrumors 65816

    Joined:
    Aug 1, 2007
    #5
    I tried to disable DNS in the services checklist (dangerous I know to start clicking buttons when you don't know what you're doing... but since it's a newly installed home server if I bork it I'll just reformat). However it re-enabled itself right away - it seems I can't turn it off.
     
  6. TheCoupe macrumors member

    Joined:
    Mar 4, 2009
    Location:
    Northern Ireland
    #6
    hi, in order for iCal server to work, you must have the internal DNS of SLS configured correctly.
    Your IP config of your server on en0 (built-in ethernet 1) via system preferences -> network should be something like:
    Configure Manually
    IP: 10.0.1.23
    Subnet: 255.255.255.0
    Router: 10.0.1.1 (your modem IP for internet)
    DNS: 10.0.1.23

    This way, the server will use its own DNS server to do lookups.
    Next, you need to configure your DNS in Server Admin.

    To know if your DNS is working correctly... open Terminal and type:
    sudo changeip -checkhostname

    it will inform you if there is an error that needs fixing, or if everything appears to be working ok...

    it's only once you have your dns working properly, that you should look into setting up other services.

    you can also add your server IP address to the DNS details of your modem, so when it hands out an IP address via DHCP, that the first DNS server given to your client machines, will be that of your SLS. Always make sure that you also get access to an external DNS address and enter this too, should you ever need to take your server offline.
     

Share This Page