Location services and SSH always on when switching iphone on.

Discussion in 'Jailbreaks and iOS Hacks' started by southerngeordie, Apr 25, 2010.

  1. southerngeordie macrumors newbie

    Joined:
    Jul 14, 2008
    #1
    Right I've been googling this for ages and finally decided just to post.

    I have an iPhone 3G, running 3.0.1, jailbroken with redsnow. I have SBSettings installed and obviously openSSH, amongst other things.

    Whenever I switch my phone on SSH and location services seem to switch themselves on. This particularly annoying as it then burns through my battery life, which is bad enough already, if I forget to switch them off. Any suggestions would be greatly appreciated. Thanks.
     
  2. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #2
    Not sure how to make Location Services default to off, but as far as SSH being on at startup I believe that to be a good thing. One of these days you can end up in a respring loop and your saviour will be the fact that SSH is available to you to intercede and fix the issue. I can't see SSH being on to have ANY effect on battery life. Location Services is another story and definitely can affect battery life.
     
  3. southerngeordie thread starter macrumors newbie

    Joined:
    Jul 14, 2008
    #3
    ok, i'll stick with ssh being on for start up, it does seem to affect the battery though. It was mainly location services I was confused by, it's only done this since I jailbroke and is really quite annoying.
     
  4. Bdubb macrumors regular

    Bdubb

    Joined:
    Mar 18, 2010
    #4
    Can't you just turn off "Location Services" via Settings>General>Location Services (toggle) "Off"?

    Or am I missing something here?

    it should not come on I have a J/B 3.1.2 3Gs and after I turn my phone back on it's still "off"

    it might be a certain app you have on Cydia that's casing it to turn on automatically.

    I just tested both methods.. "slide to turn off" and Hard Reset..Hold down home and Sleep button for a few seconds until phone restarts... both times it was still "off"

    I would check a certain app you installed lately that heavily relies on the Location Service, but not even sure if that should automatically turn it on. I have many apps that rely on L.S but non of them would turn it on without "asking" me first.

    Are you sure you are not just runnin an app and replying "allow" for LS. when the app asks you?
     
  5. southerngeordie thread starter macrumors newbie

    Joined:
    Jul 14, 2008
    #5
    I have tried turning it off both through settings etc and through SBSettings....
    I think you may have it, I'm guessing xGPS might be the cause, I only installed it when I was playing around, I'll try removing it. It shouldn't have that effect though, should it?

    - Nope that didn't work, I can't think of any other apps that would cause this...
     
  6. Bdubb macrumors regular

    Bdubb

    Joined:
    Mar 18, 2010
    #6
    it's probably SBSettings itself that turns it on, so you can use it to turn it off, can you quickly uninstall SBSettings, Test it out and see what that does?

    I bet it's SBSettings that's turning it on Automatically.

    See what it does when you remove it..
     
  7. southerngeordie thread starter macrumors newbie

    Joined:
    Jul 14, 2008
    #7
    I did agree with you.... But it's not. I totally uninstalled it and all relevant things and I've just rebooted twice and going settings - general its turned itself back to on :S any other ideas??? I don't suppose I could have accidentally altered this while changing the theme?? But I would guess this would be in totally separate folder on the phone.
     
  8. Bdubb macrumors regular

    Bdubb

    Joined:
    Mar 18, 2010
    #8
    Sorry mate, that is all I can suggest, I am all out of ideas.
     

Share This Page