Location Services icon comes on frequently, iOS6 / iPhone 5 ...

cmeisenzahl

macrumors 6502
Original poster
Oct 7, 2005
330
27
I see it come on often, for no apparent reason. But usually goes off again after a few seconds.

Seems to happen nearly every time I press the round hardware button to wake-up the phone.

I've disabled location services for all but a few apps that obviously need it, and none of them are running now. And I've even disabled LS for most system services.

I've restarted the phone with no apparent change. I don't recall this behavior with the 4S on iOS 5.x.

Any ideas or guesses?

Thanks in advance,
Chris
 

jlake02

macrumors 68020
Nov 2, 2008
2,259
1
L.A.
I see it come on often, for no apparent reason. But usually goes off again after a few seconds.

Seems to happen nearly every time I press the round hardware button to wake-up the phone.

I've disabled location services for all but a few apps that obviously need it, and none of them are running now. And I've even disabled LS for most system services.

I've restarted the phone with no apparent change. I don't recall this behavior with the 4S on iOS 5.x.

Any ideas or guesses?

Thanks in advance,
Chris
I'd shut them ALL off then start turning them on one at a time.. try to figure out what service is pinging locations all the time. Otherwise, your battery life will most likely suffer. :eek:
 

cmeisenzahl

macrumors 6502
Original poster
Oct 7, 2005
330
27
I'd shut them ALL off then start turning them on one at a time.. try to figure out what service is pinging locations all the time. Otherwise, your battery life will most likely suffer. :eek:
Thanks, I'll probably try that next.
 

cmeisenzahl

macrumors 6502
Original poster
Oct 7, 2005
330
27
Interesting. I think I might have found the culprit. Looks like it was the iOS6 Passport app.

Looking back I updated the Starbucks app a few days ago. At the time it asked me if I wanted to sync it with Passport. I said "sure." And the LS icon has been coming on frequently ever since, even though Passport wasn't technically running.

I turned off LS for the Passport app and haven't seen the behavior since.

Lesson learned. ;-)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.