Location Services Icon Constantly On

Discussion in 'iOS 8' started by mcflurry, Jun 3, 2014.

  1. mcflurry macrumors newbie

    Joined:
    Jun 3, 2014
    #1
    Hi Guys

    Anyone know why I have a constant location services icon on the home screen?

    I've been through all the apps and the only way I can make it go away is to totally switch off location services.

    Cheers
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2

    Did you check what service is using it?
     
  3. mcflurry thread starter macrumors newbie

    Joined:
    Jun 3, 2014
    #3
    How can I check that again?

    Cheers
     
  4. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #4

    Settings, privacy, location services and also under system services. Arrows that are purple means they used your location recently
     
  5. pugnut macrumors 6502a

    Joined:
    Jul 1, 2007
    #5
    App Store

    Seems to be an issue with the app store looking for a location. You can go in and set it to Never be allowed to use GPS. Solved an issue for me.
     
  6. mcflurry thread starter macrumors newbie

    Joined:
    Jun 3, 2014
    #6
    Thanks.

    So the only purple ones were Frequent Locations and App Store. But Ive set App Store to Never however it still has the purple colour arrow.
     
  7. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #7
    that App Store location service made my iPhone 5 heat up last night. Damn thing. I had to restart to make it stop.
     
  8. FelixDerKater macrumors 68020

    FelixDerKater

    Joined:
    Apr 12, 2002
    #8
    After turning it off for the App Store, you must then cycle Location Services off and back on as a whole. This solves the issue.
     
  9. bmwtech113 macrumors member

    Joined:
    Jun 10, 2010
    Location:
    Knoxville, TN
    #9
    This did not solve the issue for me.
     
  10. mcflurry thread starter macrumors newbie

    Joined:
    Jun 3, 2014
  11. benji888 macrumors 65816

    benji888

    Joined:
    Sep 27, 2006
    Location:
    United States
    #11
    hmmm, this was a problem with one of the iOS 7 betas...let me think...I think we went into location services to find which apps had that arrow next to them, turn them all off until the arrow went away up top, then turn each one back on, wait for arrow to go away...to see which app was the culprit.

    Sounds like some app is not compatible with iOS 8...imagine that :eek: (sarcasm, sorry:eek:).
     
  12. schlaufox macrumors regular

    Joined:
    Jun 18, 2013
    #12
    I solved this problem by going to Settings > Privacy > Location Services > System Services and toggling "Popular Near Me" on and then back off.

    Hope that helps!
     

    Attached Files:

  13. mcflurry thread starter macrumors newbie

    Joined:
    Jun 3, 2014
    #13

    Didnt work for me :( I can see its the app store causing it. If you set App Store to Never use location in Privacy a pop up box appears asking to change settings and then it re-activates itself and the arrow icon never goes away from the home screen.
     
  14. schlaufox macrumors regular

    Joined:
    Jun 18, 2013
    #14
    Hmm, that's odd. When I set the App Store to Never on Location Services, it would stay set to Never, but still show the purple arrow next to App Store and in my status bar.

    Then I followed the process I posted earlier and that solved the problem.

    Not sure what else you could try, but I hope you're able to solve it!
     
  15. lint2015 macrumors member

    Joined:
    Jul 8, 2013
    #15
    This is a known issue in beta 1 related to the lock screen app recommendation:

    https://developer.apple.com/library/prerelease/ios/releasenotes/General/RN-iOSSDK-8.0/index.html

    I've turned my Location Services when not required off for the time being.
     
  16. mcflurry thread starter macrumors newbie

    Joined:
    Jun 3, 2014
    #16
    Its really odd, i turn of location services totally, the arrow disappears, as soon as i switch it on again (and app store is set to never) the arrow re-appears in the top bar and the icon next to the app store turns purple.
     
  17. mcflurry thread starter macrumors newbie

    Joined:
    Jun 3, 2014
    #17
    Hmmm and now the arrow has gone! Strange bug :D
     
  18. schlaufox macrumors regular

    Joined:
    Jun 18, 2013
    #18
    Glad it's working for now. It was really draining my battery for the time I had the problem (and heating up my iPhone)!
     
  19. thegrants82 macrumors 65816

    Joined:
    Jun 15, 2013
    Location:
    Right here
    #19
    Actually, it doesn't solve anything.
     
  20. FelixDerKater macrumors 68020

    FelixDerKater

    Joined:
    Apr 12, 2002
    #20
    Well, it is what worked for me. Your other settings may have started in a different configuration.
     
  21. Seanu13, Jun 4, 2014
    Last edited: Jun 4, 2014

    Seanu13 macrumors newbie

    Joined:
    Jun 3, 2014
    #21
    Location Services Icon Constantly On

    For me Google search is keeping location services on even if the app isn't running in the background. Used to be able to swipe it out and it would quit using the service.
     
  22. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #22
    I give up on beta 1. Im not ok with disabling location services and the battery is being reported incorrectly. Oh well, beta 2 should be coming soon.
     
  23. famoussasjohn macrumors 6502a

    famoussasjohn

    Joined:
    Jul 7, 2010
    #23
    Coul you screenshot your exact settings? I've turned off everything and cycled location services on and off and back on again and still get the location icon.
     
  24. Sk8mfm macrumors member

    Sk8mfm

    Joined:
    Jul 12, 2010
  25. Mufaddal macrumors member

    Joined:
    Feb 16, 2012
    Location:
    Chicago
    #25
    I had the same issue as well. I turned AppStore to never, turned off location services, then restarted the phone and turned location services back on.

    That fixed the issue for me. Hope that helps.
     

Share This Page