Lock OSX desktop icon size

Discussion in 'macOS' started by MB100, Feb 25, 2009.

  1. MB100 macrumors newbie

    Joined:
    Oct 2, 2008
    #1
    its really annoying whenever happen to use two fingers on my multi-touch mouse-y thing and all of my icons spiral into outrageously large or ridiculously small sizes....is there a way I can lock the icon size so this doesn't happen?
     
  2. sd2009 macrumors 6502

    Joined:
    May 30, 2008
    #2
    It used to do that for me but now two finger gestures don't change the icon size on the desktop or anywhere else in Finder. I must have turned it off somehow.
     
  3. joelperlish macrumors newbie

    Joined:
    Apr 20, 2009
    Location:
    southwest phila,pa burb
    #3
    ever get the answer???

    hi there... did anyone ever figure this one out???? best, joel
     
  4. macrlz9 macrumors 6502

    macrlz9

    Joined:
    Dec 6, 2003
    Location:
    Long Island, NY
    #4
    In the Finder, go to the Finder application menu > Preferences. Click Advanced and uncheck "zoom using trackpad"
     
  5. jcb10 macrumors regular

    Joined:
    May 14, 2008
    #5
    How about on Snow Leopard?

    Anyone know how to lock icon sizes on Snow Leopard, which does not give the "zoom using trackpad" option?
     
  6. getrfreakon macrumors newbie

    getrfreakon

    Joined:
    Nov 7, 2009
    Location:
    the Hell that is Tucson
    #6
    I notice no one has posted the answer for 10.6 yet; hopefully someone has figured it out? I must have reset my sizes several times this morning; there must be an internal way to do it, or at least a 3rd party app that corrects this 'feature'. Thanks.
     
  7. CowboyVol macrumors newbie

    Joined:
    Nov 17, 2009
    #7
    Solution in Snow Leopard

    I have been trying to figure this out as well and I think I have it --- to adjust how the desktop icons behave on the pinch and spread zoom do the following:

    A) System Preferences
    B) Trackpad
    C) On the left is a list of functions --- one is Screen Zoom (Options)
    D) You can either turn it off altogether or set the key that must be clicked for the pinch zoom to work --- I set mine to COMMAND and it will only do the zoom of the icons when this key is held down -- by default it was control so I guess I left my finger there alot, but since going to command it rarely happens, but as I said you can just turn it off.
    E) once you click the key and start zooming, it does not stop happening until you the trackpad (or button) or start another application.

    Enjoy.:)
     
  8. CowboyVol macrumors newbie

    Joined:
    Nov 17, 2009
    #8
    One more little thing about the Snow Leopard fix

    Double Post - sorry
     
  9. getrfreakon macrumors newbie

    getrfreakon

    Joined:
    Nov 7, 2009
    Location:
    the Hell that is Tucson
    #9
    Thanks; I tried the solution from CowboyVol, but, unfortunately, it didn't work for me. However, I got this solution from a great guy named Floyd:

    system preferences-> trackpad:
    uncheck "two fingers, pinch open&close".

    Voila! Finally, no more problems!
    What I did do as a work around until I heard from him was to install Camouflage
    http://www.briksoftware.com/products/camouflage/
    which is donation ware; they have a vid on their site if you want to see how it works.

    I wouldn't do my work any other way now that I have it installed. HTH.
     
  10. Mickwah macrumors newbie

    Joined:
    Oct 25, 2010
    #10
    if people are still having trouble, try using BetterTouchTool (http://blog.boastr.net/?page_id=1722). you can customise the effect that any of the fancy multitouch gestures have with and without modifiers etc, this includes setting them to 'no effect'. i set up the pinch zoom with every combination of modifier to 'no action' in finder. obviously a 'lock desktop icon size' option in the desktop prefs would be ideal but this is how I've got around it for now. hopefully the new OS includes such an option!
     
  11. klundtasaur macrumors newbie

    Joined:
    Jun 26, 2009
    #11
    This is a great suggestion. BTT is a fantastic tool to begin with, and all you have to do is add 2 gestures to the "Finder" Application: Pinch In (No Action), and Pinch Out (No Action) and you're good to go!
     
  12. PaperQueen macrumors 6502

    PaperQueen

    Joined:
    Aug 16, 2007
    Location:
    Just this side of insanity (Minneapolis)
    #12
    Unfortunately, that's not working on my MBP. Even though I set the Finder as Pinch In (No Action) and Pinch Out (No Action), the desktop icons continue to balloon to gargantuan proportions. Even tried coupling Pinch In and Pinch Out with every single modifier key option (again, all as No Action), yet no luck.

    Anyone else having this same problem?
     
  13. tjb1 macrumors 68000

    Joined:
    Aug 26, 2010
    Location:
    Pennsylvania, USA
    #13
    Did you try turning off Pinch Open & Close in System Preferences > Trackpad
     
  14. PaperQueen macrumors 6502

    PaperQueen

    Joined:
    Aug 16, 2007
    Location:
    Just this side of insanity (Minneapolis)
    #14
    I actually need pinch in/out in other programs--just need to turn it off in Finder. Was swapping emails with the developer a few days ago, they seem to have gone silent now, leaving me hanging. Very frustrating.
     
  15. icemako macrumors newbie

    Joined:
    Sep 1, 2011
    #15
    Try this. In BBT, I added 4 gesture commands to keep Pinch open and close for all Apps but finder, which only works with modifier CMD.

    Under Finder:
    Pinch in No Action
    Pinch out No Action
    Pinch in + (CMD mod) Use Apple default or do nothing
    Pinch out + (CMD mod) Use Apple default or do nothing

    "Two Fingers - Pinch Open & Close" remains checked in System Preference Touchpad.
     

Share This Page