Lock screen doesn't work

Discussion in 'macOS' started by saisrujan, Feb 19, 2008.

  1. saisrujan macrumors member

    Joined:
    Aug 6, 2007
    #1
    I know this has been asked and answered a million times. But it still doesn't work for me. So, I hope someone helps me.

    System preferences -> Security
    Disable automatic login is checked.
    Require password to wake this computer from sleep or screen saver is checked.

    System preferences -> Desktop and screen saver.
    Screen saver is set to "Computer name". Testing this works. Screen saver is set to fire in 3 minutes.

    Try-1:
    System preferences -> Expose and spaces -> Expose
    Bottom right corner set to "Start screen saver".
    I close this window and move my mouse pointer to the bottom right corner.
    Nothing happens.
    Change the bottom right corner to "Sleep display" and move the mouse pointer there. Works.
    Change the bottom right corner to "Dashboard". Works.
    Change it back to "Start screen saver". Doesn't work.

    Try-2:
    Keychain access preferences
    Show status in menu-bar is checked.
    I see the lock icon on the menu bar.
    Click on it and choose "Lock screen". Nothing happens.

    I've tried this a million times and it never works. What am I missing? I'm using Macbook Air on 10.5.2. It asks the password when I put the notebook to sleep and wake it back up. Otherwise, the display sleeps, but as soon as I touch something, I am back to my usual desktop.

    Am I asking too much from my first mac when all I want it to do is to lock the screen? Please help.
     
  2. applefan69 macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #2
    Nothing seems to be wrong, except for what yuor doing. Your gonna feel silly when i tell you this but. When you set a hot corner to activate screen saver. Moving your mouse to the corner doesnt instantly put you in screen saver. You need to hold your mouse in the cornr for about 5 seconds. Apple makes that delay so during regular computer use, you dont accidently start your screensaver and get annoyed. :)

    I hope i helped. Btw how do you like your macbook air? Another thing, welcome to the Mac family, you'll see we try to treat each other right :)
     
  3. saisrujan thread starter macrumors member

    Joined:
    Aug 6, 2007
    #3
    Aah... I wish it was that simple. I've tried letting the mouse pointer stay at the bottom-right corner for about 40-50 seconds. Nothing happens.

    I haven't tried re-starting my machine though. Do you think it will make a difference? (Like the windoze machines?)

    I like the Macbook Air a lot. But the only problem is that every other laptop feels huge and clumsy once I got used to the MBA. And it runs OS X and XP Pro simultaneously without hiccups. Now, that's more than what I need from an ultra-portable.

    And thanks for the welcome. Ever since I picked up my iPhone, I knew I would go the Mac way. And the macrumors forum and Apple community has been very friendly and helpful. I will do whatever I can to return the favor back to the community by helping out future newbies.

    But first, I want my issue fixed!
     
  4. applefan69 macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #4
    Hmmm, this is very odd then that its not working for you.

    I just tried on my macbook. I'm running OS X 10.5.2. Heres EXACTLY what i did

    - I open system preferences, went to the security tab
    - I checked the box that said "Require password to wake this computer from sleep or screensaver"
    - I then checked the box that said "disable automatic log-in"

    Then to test this out I pyut my computer to sleep, when i woke it back up it wouldn't show me anythin but a black screen until I entered my password. (this is what you want your mac to do, right?)

    Next I tried making my mac go into screen saver. As soon as I tried to get rid of the screen saver, i had to enter my password. Once again thats what you want your mac to do, right?

    So, i tested it out it works 100% on my mac, and if it's not workin for you then i have NO idea what could be wrong.

    Im not eager to say something like this, and im pretty doubtful of this,but then again who knows what the problem could be. But there IS a chance somehow your installation of leopard didn't work 100%, and maybe there is a file missing from your system and without that file your mac doesn't know how to lock oyur screen. Although im doubtful of that, cause i've never heard of such a case before.
     
  5. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
  6. saisrujan thread starter macrumors member

    Joined:
    Aug 6, 2007
    #6
    Resolved - finally

    I repaired permissions. Didn't work.

    Then, I tried to shut down my machine. I kept getting errors like

    "Shut down timed out because application XXX did not quit. Please quit the application and choose log off..." or something to that effect.

    It listed ALL applications I opened (and quit) ever since my last logon. Finally it said

    "Shut down timed out because application Finder did not quit...."

    Now, I can't possibly quit Finder. I scratched my head for a couple of seconds, and forced the machine off, and re-started it.

    Everything's fine now. Both the Keychain access method and hot corner method are working.

    I am not sure if repair permissions helped here, even though it complained about some problem with permissions on the Applications folder. If anyone else ever face this problem, try re-starting the machine first.

    Thanks for your help guys.
     
  7. af3556 macrumors newbie

    Joined:
    Feb 8, 2008
    #7
    I've had the same kind of problem, also on the same hardware (Macbook Air w/ 10.5.2). I have the Keychain Access icon in the menu bar and use that menu's "Lock Screen" item. It usually works, but every once in a while it stops working until I reboot.

    I use this same process successfully on my other Macs.

    In situations where I don't want to reboot, I've found closing the lid works (I have 'require password to wake' set in Security prefs).

    Ben
     
  8. robc macrumors newbie

    Joined:
    Apr 28, 2008
    #8
    After almost 20 years in technology working mostly in the Windows world the first thing I would have asked someone was did you reboot.

    Funny how after only a few months on a Mac the thought of rebooting never even occurred to me. My system was running so well with the exception of this one little problem.

    Anyway I also have Macbook Air with 10.5.2 and a reboot solved the problem.

    I also had to force the machine off.
     
  9. af3556 macrumors newbie

    Joined:
    Feb 8, 2008
    #9
    This bug's still here as of 10.5.4...

    Damned annoying, especially as I'm supposed to be the security guy around here and it's really not a good look to inadvertently leave the screen unlocked - which means I can't just click "Lock Screen" and walk away, I have to actually *wait* for the screensaver to kick in before I can go.

    I lodged a bug report on this back in March, Apple marked it as a duplicate (5576340) but don't seem to have done squat since then.
     
  10. tmelvin macrumors 6502

    tmelvin

    Joined:
    Mar 17, 2008
    #10
    Just tested this on my 2.2MB/10.5.4, and no problem at all. Worked like a charm whether it was sleep or screensaver.:confused:
     
  11. af3556 macrumors newbie

    Joined:
    Feb 8, 2008
    #11
    It's an intermittent problem. All will be fine and dandy until "something" happens to break it. I actually went for some time without an issue after the 10.5.3 (or was it .4?) update, and of course just when I got to thinking "gee, I'm glad to see the end of that little issue" then it breaks again.

    My MBA is currently in the broken state - and has been for the last few days. I have too much open to log out / reboot right now, maybe over the weekend.

    Ben
     
  12. sadyhr macrumors newbie

    Joined:
    Sep 8, 2008
    Location:
    Denmark
    #12
    Problem is also in 10.4.11

    For the moment I have the same problem in OS X 10.4.11 with neither screensvaer nor Lock Screen nor sleep asks for pasword.

    I have had it working until some days ago - maybe stopped after crashing; but I really don't remember the occasion.

    It does work on my other machine running 10.4.11, so I don't think it's software version dependent. And it's the same problem on all user acounts!
     
  13. live4ever macrumors 6502a

    Joined:
    Aug 13, 2003
    Location:
    Thunder Bay, ON
    #13
    Anyone find a resolution to this? On 10.5.5 with a PPC and both the lock screen and start screen saver hot corner don't work. I've tried deleting all prefs as well so it must be a bug. Help by reporting feedback to Apple if you can.

    http://www.apple.com/feedback/macosx.html
     
  14. af3556 macrumors newbie

    Joined:
    Feb 8, 2008
    #14
    10.5.2 ... 10.5.3 ... 10.5.4... and now 10.5.5 and still not fixed.

    In my previous update I noted Apple had marked my report as a dup, but either I got the ID wrong previously or Apple changed it. My report's now marked as a dup of 5683725.

    If this is affecting you, please tell Apple. If you have an ADC account, even better to lodge a bug report.

    Argh.
     
  15. sadyhr macrumors newbie

    Joined:
    Sep 8, 2008
    Location:
    Denmark
    #15
    Sort of solution

    Some month ago I wrote this:

    I ended up reinstalling my system, which solved the problem.
    So I guess, there might have been some sort of corrupted prefs, but I really can't be sure.

    I did an archive and install and re"loaded" my user settings.
     
  16. WICKEDfour macrumors newbie

    Joined:
    Jun 22, 2003
    #16
    Thread Bump for Posterity

    Sorry for the bump, but this is the top hit on Google for "Mac OS X lock screen doesn't work," so I thought I'd include the following solution from a thread by MacRumors user mciarlo:

    Emphasis mine. This solved my seemingly identical problem as well.
     
  17. Windmarble macrumors newbie

    Joined:
    Apr 25, 2011
    #17
    I hate to bring a post back from the dead but this is the closest I have come to finding a solution.

    This doesn't work for me Browse to Home>Library>Preferences and drag com.apple.systempreferences.plist to the desktop.

    I have about 25 macs bound to an AD domain. I have only two that will not lock the screen. Well the screen turns black, but the user isn't prompted to put in their credentials once they move the mouse or keyboard. I have no idea why this doesn't work. The settings are all same coming straight from the image. :mad::mad::mad::mad:

    Any other thought or solutions to try?
     

Share This Page