Lock the computer with closing lid?

Discussion in 'Mac Basics and Help' started by DarkHeraldMage, Nov 13, 2007.

  1. DarkHeraldMage macrumors 6502a

    DarkHeraldMage

    Joined:
    Oct 5, 2007
    Location:
    Fort Worth, TX
    #1
    Morning all! Recent switcher here with a security question. I have my MBP set to lock upon closing the lid, that way when I open it again it requires my admin password. However, this disconnects me from the internet when closing the lid and that's not always what I want to do. What I'm looking for is a shortcut to "locking" the computer without having to put it to sleep first. I want this primarily for while I'm in school if I have to step out of the class for a second - I don't want everyone looking at my screen or touching my computer while I'm gone. Thanks for the help!
     
  2. CrzyCanuck72 macrumors 6502a

    Joined:
    Jun 10, 2003
    #2
    easiest way is to go to Keychain (Applications>Utilities), go to Preferences, and choose 'Show in menu bar'. That will put a little lock icon in the menu bar. If you click on that, one of the options is to lock screen. That will bring up a black screen that requires your password to get rid of, but will leave all processes running in the background, including internet.
     
  3. yippy macrumors 68020

    yippy

    Joined:
    Mar 14, 2004
    Location:
    Chicago, IL
    #3
    You can set it so that you need a password to get back from a screensaver. This sounds like what you need.

    In Leopard, under System Preferences->Security->General there is a check box to require password to wake from sleep or screensaver. This means simply activating the screen saver (I use a hot corner) will require a password to see the screen again.
     
  4. DarkHeraldMage thread starter macrumors 6502a

    DarkHeraldMage

    Joined:
    Oct 5, 2007
    Location:
    Fort Worth, TX
    #4
    This sounds like what I'll do. I'll look into it when I get home. :D

    Thanks for the advice, but until I get used to the new mac I know hot corners will only annoy the hell out of me. Especially if one of them activates a screensaver which requires my password to get out of. Maybe in time, so thanks for the suggestion!
     
  5. saisrujan macrumors member

    Joined:
    Aug 6, 2007
    #5
    neither works

    Trial-1
    In system preferences for Expose, I have set the lower right corner as an active screen corner to "Start screen saver". I move the mouse to the lower right corner, and nothing happens. I change it to "Sleep display", or "Desktop" or anything else, and all that works. I just can't seem to be able to start the screen saver.

    Trial-2
    In keychain access preferences, I enabled "show status in menu bar". There's a lock icon on menu-bar. I choose that and select lock-screen, nothing happens.

    I've verified that the other known setup is correct. "Disable automatic login" is enabled, "Require password to wake this computer from sleep or screen saver" is enabled.

    The screen saver is set to "Computer name", but I don't think that makes any difference.

    I am not able to figure out how to make this work. Please help.
     

Share This Page