Locked Disk Won't Boot! Please help

Discussion in 'Mac Basics and Help' started by kirley09, Jun 12, 2013.

  1. kirley09, Jun 12, 2013
    Last edited: Jun 12, 2013

    kirley09 macrumors newbie

    Joined:
    Jun 12, 2013
    #1
    I'm so fed up with this...

    This is a 2010 MBP Snow Leopard.
    Upgraded to (not a clean install) Mountain Lion without doing software updates beforehand, think it got corrupted :( Install was longer than usual, 50 minutes.

    At first turned on and worked, but then it wouldn't boot at all, show a stop / prohibitory sign.
    It said drive was LOCKED when trying to reinstall ML (using bootable USB flash drive)

    I tried:

    Reformatting to journaled, FAT32, NTFS (on XP laptop), journaled again (as an external drive).

    Swapping this drive on another macbook. I was able to fresh install ML with no problems! But when putting back in original macbook, still same stop sign problem.

    Ran Disk Warrior repair permissions. Same plus unlock with BatChmod.
    Apparently they worked, because on disk utility says "Owner's Enabled: Yes", before was "No"

    Yes I tried Get Info - ignore permission, enable all options to read/write, leave the lock option unchecked.

    I also did a verify and repair permissions, and verify and repair disk itself - came up OK (on disk utility) - drive doesn't seem to be dead!

    With Snow Leopard DVD, it reads "Mac OS X Base System" as only 1.26GB drive !!! ???

    Now with bootable flash drive, disk utility doesn't read the hard drive at all.

    Pressing Option at startup sometimes reads all 3: drive, recovery, and bootable USB.. but now it only reads the bootable one.

    Someone help please. Thanks!
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    Even though you've tried it in other machines and have re- formatted the drive, all the symptoms point to it being on its way out.

    Can you run the Apple hardware tests from your original media?
     

Share This Page