Locked Out !!! ( of external Hard Drives on MacMini running Snow Leopard )

Discussion in 'Mac mini' started by HoberMallow, May 13, 2012.

  1. HoberMallow macrumors newbie

    Joined:
    Feb 27, 2010
    #1
    I’m not sure how this happened but, while I was changing disk permissions, I was locked out of both of my USB external hard drives.

    Now both drives show up on the desktop w/ the “locked” symbol on the bottom left hand corner of the disk icon. I am now unable to open either drive.

    So far I’ve tried the following:

    1. Tried to run disk utility. Now the verify and repair disk permission buttons are shaded out and unavailable. It allows me to repair both disks but nothing changes.
    2. Highlighted the drives and tried “Get Info”. The sharing and permissions window show my user name, staff, and everyone as “custom” privilege. I can unlock the disk icon at the bottom of the window and try to change the settings of all 3. It changes while clicking on “read and write” but then immediately reverts to “custom”. Choosing “ignore ownership” does not help. (When this first happened, I did not choose the “custom” setting while changing disk permissions)
    3. I have booted from a flash drive boot stick w/ a minimal system on it. I repeated the above with the same results.
    4. I change user to “root” access. Again, got the same results although I can open the drive’s to the directory but not make any changes to the drive or remove the locks.
    5. I have booted the drives on my other machine -- an older iMac-- but the drives are still locked and with same results as above.
    6. I have ran DiskWarrior over both drives while booted from the boot stick. DiskWarrior says the drives are OK after running repair.

    I am now unable to back up may iMac and have lost access many valuable and irreplaceable files on the external drives.

    Machine specs follow. Thank you in advance for your help!

    BNEX

    My Mac:
    OSX 10.6.8
    Model Name: MacMini
    Model Identifier: Macmini4,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 3 MB
    Memory: 2 GB
    Bus Speed: 1.07 GHz
    Boot ROM Version: MM41.0042.B00
    SMC Version (system): 1.65f2
     
  2. OLDCODGER macrumors 6502a

    Joined:
    Jul 27, 2011
    Location:
    Lucky Country
  3. harddrivefailur macrumors newbie

    Joined:
    May 24, 2012
    Location:
    Irvine, CA
    #3
    Have you considered calling a professional data recovery company? Usually, they will provide you with a good amount of tech support for free. You just have to make the call.
     
  4. notchfiend, Jun 24, 2012
    Last edited: Jun 24, 2012

    notchfiend Guest

    Joined:
    Jan 11, 2012
    #4
    Locked Out Too...

    ...except my machine is a PowerMac G5. My question is, "What if I can't get Terminal to work?" When I open it, I get the message:

    login: PAM Error (line 400): System error
    login: Could not determine audit condition

    [Process exited - exit code 1]

    instead of the usual computer name.

    I know it is a system error but this doesn't sense to me. I'm on the G5 as I write this. I, too, had just finished changing permissions when I was locked out of my three USB's.

    I will supply the G5's specs but will await any responses to this post, please. In the meantime I will try the drives on my G4 laptops.

    TIA

    nf

    Model Name: Power Mac G5
    Model Identifier: PowerMac11,2
    Processor Name: PowerPC G5 (1.1)
    Processor Speed: 2 GHz
    Number Of CPUs: 2
    L2 Cache (per CPU): 1 MB
    Memory: 2 GB
    Bus Speed: 1 GHz
    Boot ROM Version: 5.2.7f1
    Hardware UUID: 00000000-0000-1000-8000-0016CB3922FC
     
  5. Cisco_Kid macrumors 6502

    Cisco_Kid

    Joined:
    Apr 24, 2005
    Location:
    British Columbia
    #5
    Install MacDrive on a Windows Virtual machine, then forward the USB drives to the vm and open them with MacDrive, copy the data out of the drives to somewhere; format the drives under osx and replace the data.

    I had this same problem once, I used the above method to get my data, Windows/MacDrive does not pay any attention to permissions created/set with osx.
    http://www.mediafour.com/products/macdrive
     
  6. notchfiend Guest

    Joined:
    Jan 11, 2012
    #6
    Formatting the drives seemed like a drastic measure. So, I just unlocked them on my iBook and that worked. For your future reference, something to fix the Terminal problem:

    http://anshu-manymoods.blogspot.com/2009/10/mac-terminal-error-could-not-determine.html

    A couple of caveats:

    The Error number is different. Mine was 400, this is 396. It still fixed mine, though.

    usr/bin/login is not a folder. usr/bin is, however. You can delete the 'login' command from there.

    Hope this helps.

    Hi to whoever is reading this and pulling their hair out.

    :D
     

Share This Page