Locked out of my external HD can anyone help?

Discussion in 'Mac Accessories' started by hsedoctr, Mar 8, 2010.

  1. hsedoctr macrumors newbie

    Joined:
    Mar 8, 2010
    #1
    My iMac dual core died last weekend and I have been given a similar model by my son. I cannot access my external hard drive running time machine at all. Error states I do not have sufficient access privileges. In the "get info" window I cannot change the privilege settings (it is listed as "custom"). Also the HD disc icon is showing up locked in the lower left corner where it wasn't on my old machine. Anyone have any suggestions?:confused:
     
  2. gsahli macrumors 6502a

    gsahli

    Joined:
    Jun 1, 2007
    Location:
    Chicago
    #2
    Use the Terminal to run this command:
    sudo chflags -R nouchg /Volumes/extern_drive_name {& RETURN}
    (sudo means superuser/admin user - you are asked to type your admin password - but it doesn't let you see it as you type!)

    PS - you don't have to type the /Volumes/etc - just be sure to type a space, then drag the external drive icon to the Terminal window - it enters the correct path and name for you.

    This is a very common problem for Leopard and Snow Leopard - you would have found it if you searched.... HTH
     
  3. hsedoctr thread starter macrumors newbie

    Joined:
    Mar 8, 2010
    #3
    Thank you so much gsahli!! Worked like a charm.

    I actually searched another forum first and was given several commands to try in Terminal, none of which worked. The command you gave me was one of them, but the space before dragging my HD icon to the window was the difference.

    Thanks again!:D
     

Share This Page