Resolved Lockinfo + Popup Blocker

Discussion in 'Jailbreaks and iOS Hacks' started by AnionicStrength, Jan 23, 2012.

  1. AnionicStrength, Jan 23, 2012
    Last edited: Jan 23, 2012

    AnionicStrength macrumors member

    Joined:
    Dec 28, 2010
    #1
    I have Lockinfo and Popup Blocker installed on 5.0.1. I am trying to find a way to suppress the notification popups from the native OS as seen below.

    [​IMG] [​IMG]

    The obvious choice is to disable the notification on the Lockscreen from Settings > Notifications > Messages > View in Lock Screen > Off. However, while the phone makes a sound, it does not turn the screen on when the message arrives.

    Popup Blocker doesn't appear to work at all.

    Has anyone found a work around to suppress notifications on the lockscreen but still have the screen turn on?

    Thanks in advance.
     
  2. los318 macrumors 6502

    los318

    Joined:
    Jun 29, 2010
    Location:
    Austin, Tx
    #2
    Have you tried:

    Settings - Lockinfo - Lockscreen - Alert Popups:
    Enable:
    Block Popups
    Wake When Blocked

    Settings - Lockinfo - Plugins - Messages:
    Enable:
    Wake on new Message
     
  3. F123D macrumors 68040

    F123D

    Joined:
    Sep 16, 2008
    Location:
    Del Mar, CA
    #3
    In apples notification center, you have to have "View in Lock Screen" ON to wake the screen up when a notification comes in.

    To turn off pop ups, you have to go to settings > lockinfo > lockscreen > alert popups > and turn on "block popups", "wake when blocked".

    That's how mine is set and I have no popups and all alerts go into lockinfo's lockscreen.
     
  4. AnionicStrength thread starter macrumors member

    Joined:
    Dec 28, 2010
  5. kwando macrumors member

    Joined:
    Jan 25, 2012
    #5
    Thanks! This worked for messages/SMS, but is there a way to get this to work for Calendar alerts?
     
  6. F123D, Jan 25, 2012
    Last edited: Jan 25, 2012

    F123D macrumors 68040

    F123D

    Joined:
    Sep 16, 2008
    Location:
    Del Mar, CA
    #6
    Make sure "view in lock screen" is turned on in notification center for calendars and that the "notification" plugin is enabled in lockinfo. Under calendar plugin in lockinfo, turn on view in "show in notifications".

    Thats the only way I can get calendar alerts to show up without the default apple popup.
     

Share This Page