Log In Questions

Discussion in 'OS X Mountain Lion (10.8)' started by butterwm, Jul 8, 2012.

  1. butterwm macrumors member

    Jun 25, 2012
    On our new iMac I set up three profiles so we each have our own. The setup went fine except it requires a password every time from the users before they log in. If you go under users and groups-login options it doesn't give you an option to turn the passwords off. The only option it gives is automatic login (which is password free) but you have to pick which user it always starts up with. Is there any way of still having the login profiles but with no password requirement? Also, is there a way to delete the guest account that shows up at the login screen?
  2. CyBeRino macrumors 6502a

    Jun 18, 2011
    Just set an empty password. And throw all security out the window.

    And yes, the guest account can be disabled in users and groups preferences.
  3. butterwm thread starter macrumors member

    Jun 25, 2012
    Thanks--the blank password did the trick for the first.

    I have the guest account is disabled and the guest user icon still shows up at the login screen. Any way of getting rid of it all together or hiding it?
  4. TheGdog macrumors 6502


    Sep 4, 2010
    North Carolina, USA
    Not that I am aware of. It actually boots into a guest user mode of others can use your computer without touching your files. Its not really a user account.
  5. Sesquipedalian macrumors newbie

    Jun 27, 2012
    It is a little confusing, butterwm, but basically there are two sorts of Guest Account that can appear at the login screen, depending on your settings. This article sums it all up nicely: http://osxdaily.com/2011/10/13/disable-guest-user-account-mac-os-x-10-7-2-login-screen/

    Note: the interface has been updated since that article was written. In 10.7.4, you need to press the Advanced button at the bottom of the Security preference pane to get to some of the options shown in the article.
  6. CyBeRino macrumors 6502a

    Jun 18, 2011
    Oh, right it's that one. You can turn that off by going to sysprefs -> security and privacy -> general -> advanced and turning on 'disable restarting to safari etc'.

    Ah, too late.

Share This Page