Log weirdness: "setting hostname to" a computer it shouldn't know about?

Discussion in 'macOS' started by Makosuke, Oct 1, 2005.

  1. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    I'm sittin' at my Mac minding my own business editing some text when I hear the HD grinding away for no apparent reason (no cron jobs or standard maintenance). I peek at the Activity viewer to first see a "sort" process then "makewhatis" eating about half of one processor for a few seconds. I have absolutely no idea why they'd have launched themselves for no reason, so I go to peek at the logs and see if anything untoward is showing up.

    Somebody appears to be portscanning me, which isn't uncommon, but there's no network traffic and nothing really odd shows up, so I'm assuming it was just Spotlight indexing or something...

    ...except now I'm weirded out by something entirely different: Every time my computer has woken up today, it has first set the hostname to the [my]-computer.local I'd expect, but then a few seconds later it sets it to something entirely different--specifically, the name of one of the laptops at work.

    This is seriously weirding me out, because there is absolutely NO reason my home computer would even know about the existance of that laptop, let alone be setting its hostname to it's network name--they have never been connected to each other, EVER.

    Can anybody think of any reason this might be happening? What on earth is going on here? Here's a (slightly cleaned, for no reason other than paranoia) log snippet, for reference:

    Oct  1 20:30:11 XXX-Computer configd[32]: posting notification com.apple.system.config.network_change
    Oct  1 20:30:11 XXX-Computer lookupd[1280]: lookupd (version 365) starting - Sat Oct  1 20:30:11 2005
    Oct  1 20:30:11 XXX-Computer configd[32]: setting hostname to "XXX-Computer.local"
    Oct  1 20:30:13 XXX-Computer launchd: Server 1b837 in bootstrap 1103 uid 0: "/usr/sbin/lookupd"[1280]: exited abnormally: Hangup
    Oct  1 20:30:13 XXX-Computer configd[32]: posting notification com.apple.system.config.network_change
    Oct  1 20:30:13 XXX-Computer configd[32]: setting hostname to "[work computer name]"
    Oct  1 20:30:15 XXX-Computer lookupd[1281]: lookupd (version 365) starting - Sat Oct  1 20:30:15 2005
  2. iMeowbot macrumors G3


    Aug 30, 2003
    You might want to peek around in the Netinfo Mangler, under machines, and see if the name happens to be there. I ran into the same log weirdness once and found that I had an old entry left over from a static addressing arrangement I was using a long time ago and had forgotten about.
  3. Makosuke thread starter macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Mm-nope, neither a spotlight content search nor a search in Netinfo Manager finds that text string or anything remotely similar to it (it's serc-alpb, if by some bizare coincidence that string has another meaning). And there's nothing in /etc/hosts, either.

    Every single time the machine wakes from sleep.

    Going through the past logs, I have at least found a connection--it started on a night when I had the laptop with that name in the house (I'd taken it home to download some updates, as the network folks take FOREVER to get stuff on the campus DHCP database). The weird thing is as far as I remember I NEVER hooked it up to my home computer--I only plugged it directly into the DSL modem, and I cannot figure how that would lead to those log entries.

    Even if I had hooked it up, I don't see how my Mac could've "caught" that hostname...
  4. Korpios macrumors newbie

    May 23, 2006
    Having run into the exact same issue myself, and having come across this thread while attempting to figure it out, I thought I'd post the answer. :)

    OS X is initially setting your hostname to what's set for your Computer Name in Sharing; however, if you're set up for DHCP and you match a current lease on your DHCP server (i.e., match the IP address of another recent user), OS X will then set your hostname to whatever the DHCP server currently has for that lease.

    This freaked me out incredibly at first, as I had just reformatted (having just purchased my first Mac and wanting to see how the installer worked) and *knew* I had not yet changed the Computer Name in Sharing -- yet my system hostname at the Terminal prompt was indeed changed to what I had previously set, pre-format. I grepped around, not finding the name anywhere save log entries; I thought either the format didn't actually properly wipe everything, or I was losing my mind. :D Finally I logged into my router (it's a Linksys WRT54GS running OpenWRT), and found the hostname in the current leases file. I then manually set my Mac's IP to something different, and volia! -- the hostname was back to what I expected.

    I hope this helps save someone from the same paranoia I went through. ;)
  5. Makosuke thread starter macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Funny to see a question I posted last year pop up again right when I'm getting back into society. I eventually figured this out myself--well after I posted this--but by that time I was so sick I didn't think to come here and share the answer.

    In hindsight, it makes perfect sense, as of course your hostname on any DHCP system should be whatever the DHCP system tells you it is. Interesting that the modem decides to pull the hostname from the computer connected to it.

    An easy way to resolve this would be to reboot your modem or router, I assume. Just renewing the DHCP lease might do it, but that would depend on how the router handles this business.

Share This Page