logging in as root/permission problems

mmoin

macrumors regular
Original poster
Jun 15, 2001
138
0
So I just got my iBook today, and it's cool, except I'm having a bit of a problem with permissions. I connected my iBook to my old PC laptop via ethernet, and copied over most of my stuff. However, now that I copied everything over, it won't let me delete any of what I've copied over (I want to move my music over to my iTunes folder, for example). When I try, it returns the message- "The item cannot be moved to the trash because it cannot be deleted". How can I delete items that I transferred over?

I've tried repairing permissions, and it didn't fix it. Also, I tried logging in as root, and it wouldn't let me log in- the username and password are both "root", right?

Thanks, Andrew
 

rainman::|:|

macrumors 603
Feb 2, 2002
5,438
2
iowa
You must activate Root by using Directory Access in your utilities folder. Then choose a password. If it was just "root", that'd be a good way for hackers to screw you royally, wouldn't it? What you might want to do here is repair permissions off of the install CD. sounds like that's your problem, since you created the files when you copied them, you should have full access including the ability to delete them.

Try repairing permissions before you mess around with root. You're likely to damage your system if you start playing around with it--

:)
pnw
 

mmoin

macrumors regular
Original poster
Jun 15, 2001
138
0
but...

The thing is that I didn't actually create them- I copied them when I was on my dell laptop, connected via Samba. So, I think my iBook might think that I'm not the original creator of the files and can't delete them.

How do I enable root in directory access? I've repaired permissions after booting from the install CD, and it didn't fix the problem.

thanks for the help so far.
 

mmoin

macrumors regular
Original poster
Jun 15, 2001
138
0
What I ended up doing instead was just copying the files from the directories, so I had ownership over the new files. Then, I logged in as the old account from my dell and deleted the old files. Then, I just deleted the account. Thanks for your responses, though- I was looking for how to enable the root user just in case I needed to use it.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.