Logging into old account on external HD

Discussion in 'Mac Basics and Help' started by ZapRowsdower, Nov 19, 2009.

  1. ZapRowsdower macrumors newbie

    Joined:
    Nov 19, 2009
    #1
    Hello all first post here, long time lurker.
    Ok here's my problem, I recently purchased a universal drive adapter to plug in my old macbook pro's old internal hd, (have some itunes content I need to get off of it).

    Everything works fine until I get to my old account folder on the external hd, the folder is completely empty. I am guessing this is due to the account being password protected.

    Is there any way to access this folder (I know the old password)? some command enter the password and get file permissions?

    I hope that made sense. Thank you for looking.
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
  3. ZapRowsdower thread starter macrumors newbie

    Joined:
    Nov 19, 2009
    #3
    Honestly, not a clue. Havent been on that drive in almost a year now and I can't remember. :(
     
  4. MWPULSE macrumors 6502a

    MWPULSE

    Joined:
    Dec 27, 2008
    Location:
    London
    #4
    i suppose it would be silly to suggest the obvious kinda stuff.. like repairing permissions on the drive, and/or doing a get info> permissions check?
    :)
    PTP
     
  5. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #5
    I don't think a login password would prevent you from accessing the files on the drive once it's no longer a boot drive. At least my CCC (Carbon Copy Cloner) backups work that way.

    However if the password is what's causing the files not to be visible you could try this, if the old hard drive has a complete OS etc. on it you could try booting from the external hard drive and once booted you could log in with your password and then eliminate the password, boot back to your new hard drive and you should be able to get your stuff as it will no longer be password protected.
     
  6. ZapRowsdower thread starter macrumors newbie

    Joined:
    Nov 19, 2009
    #6
    Thanks for the help so far everyone.
    Repaired the disk permissions using 'Disk Utility" and that did nothing, tried to boot it using the 'Startup Disk' program, it would reboot and just sit at the white screen with the apple logo.


    Just tried to use 'Migration Assistant" and when I try to transfer the user folder it says 'User accounts protected by FileVault can't be transferred.' is there any way around this?
     
  7. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #7
    This is a OS X Tiger tip so I have no knowledge if this will work with the OS you're running but you could try this:

    Mac OS X Hints: 10.4: Move a FileVault home directory between Macs
     

Share This Page