Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

guitarkevin

macrumors newbie
Original poster
Mar 29, 2021
1
0
Hello,
I'm trying to determine what the latest version logic/motherboard is hot swappable with a late-2011 chassis. One w/o integrated RAM or retina.

I'm kind of sure I can go to Mid-2012, which will do the job for Pro Tools First system requirements (Mojave 10.14.5 or Catalina 10.15.6 or higher). My OS tapped out at Mojave 10.13.6. But for the cost, I might as well get the latest possible board to handle any system requirements Pro Tools may throw out there.

Any help or advice would be appreciated.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.