Logic opening Garage Band

Discussion in 'Mac Apps and Mac App Store' started by jayducharme, Feb 12, 2015.

  1. jayducharme macrumors 68030

    jayducharme

    Joined:
    Jun 22, 2006
    Location:
    The thick of it
    #1
    This is really bizarre, and I'm wondering if anyone else has encountered it.

    I teach at a college, and this year we finally have installed Logic Pro X on our classroom computers (2008 Mac Pros) and the teacher's machine (2013 iMac). There are multiple user accounts on the teacher's computer. So I logged in to my account to demo Logic X for my students. I clicked on the Logic icon. The loading window came up (with Logic 10.1 showing). But when the menu screen appeared for choosing a project, it was Garage Band's menu. The menu bar at the top of the screen showed Logic's menus, though. So I chose a "vocal" project, and the project opened. It was Garage Band, complete with the fake wood strips on either side. But again, the menu bar said I was in Logic. I was flummoxed. I check my students' computers (the Mac Pros), and Logic opened fine on all their machines.

    So I quit "Logic Band" and went to my Library Preferences, deleting all the Logic and Garage Band plist files. I restarted the iMac, logged back in, restarted Logic -- and it was still Garage Band.

    Next, I restarted the iMac again but this time logged in to the administrator account. This time Logic opened perfectly. But then a new problem cropped up. When I brought sounds onto multiple tracks and tried to show them how to copy and paste audio, my computer refused to copy and paste with the usual CMD-C, CMD-V controls. I had to right-click to get the copy and paste options to work.

    I use Logic X at home all the time and on my office computer, and have had no issues. Any ideas what might be going on?
     
  2. jayducharme thread starter macrumors 68030

    jayducharme

    Joined:
    Jun 22, 2006
    Location:
    The thick of it
    #2
    Thanks to The Art of Sound on Apple's discussion boards for the answer: Logic actually has that Garage Band look by default now. To turn it off, simply go to Preferences > Advanced Tools and check the Advanced Tools. I had done that at on my home Mac but had forgotten all about it because when you first install Logic, it asks you if you want the Advanced Tools. I never thought about it after that.
     

Share This Page