Logic pro 9.1.8 and OSX Mountain Lion Issues

Discussion in 'Digital Audio' started by chaseme2200, May 12, 2013.

  1. chaseme2200 macrumors newbie

    May 12, 2013

    I have recently upgraded my version of logic pro 9 to 9.1.8. It was working fine the other day but for some reason now it will not allow me to open up a new session nor will it allow me to open up any templates. I can open up older sessions but whenever I try to open a blank session nothing happens. i have closed out logic and tried that over and over and still the same response. Also, I have shut down my computer numerous times and still the same thing. I only started having these problems when I upgraded my system to OSX 10.8.3 Mountain Lion. Does anyone know what the cause of this could be? Also, how can I fix this?

    I have the Intel core 2 duo, 8GB RAM, 120GB out of 600Gb available HD space, and Motu Audio Express audio interface


  2. spoonie1972 macrumors 6502a

    Aug 17, 2012
    have you tried it in both 32 and 64 bit mode?
  3. chaseme2200 thread starter macrumors newbie

    May 12, 2013
  4. spoonie1972 macrumors 6502a

    Aug 17, 2012
    get info (Command+i) on the Logic icon when the application isn't running - you can switch it to 32 or 64 bit w/ a checkbox.

    i'll admit, i haven't moved to ML because I've heard of nothing but issue after issue.
  5. chaseme2200 thread starter macrumors newbie

    May 12, 2013
    Thanx man! Ya that fixed it. Now however, When recording a session I get a crackling in the recordings and audio. smh. It's like one thing after another. Ya I feel you. Ever since I've downloaded mountain lion I've had nothing but problems with Logic
  6. ChrisA macrumors G4

    Jan 5, 2006
    Redondo Beach, California
    Buffer lengths need to be longer. It wil add to latency so not too long.
  7. chaseme2200 thread starter macrumors newbie

    May 12, 2013
    Ya. That's what I thought so I went from 256 to 512 and even 1024. However, I'm still getting some clicks in the playback. Also, I'm getting an error that says "32 bit audio plugin bridge quite unexpectedly while using the auto tune ss plugin." (I have autotune 5) Also, I keep seeing tremendous cpu usage when I only have 6 audio tracks open with 2 plugins on each. I never had this problem before with the snow leopard OSX.
  8. spoonie1972 macrumors 6502a

    Aug 17, 2012
    i still run my VEP5 box on snow leopard.

    I haven't run into any issues on Logic (other than the usual nonsense of 32-bit bridge randomly crashing, and no write-picture-to-file in 64 bit mode) using Lion.
  9. Volo831 macrumors newbie

    Oct 4, 2013
    I just upgraded my to OS X 10.8.4 but my Logic Pro 9 won't work

    I had a lot of work on my logic pro 9 but since I upgraded my software to OS X 10.8.4, it says the version of my logic pro is not compatible w/ it.. I lost my installation disc for logic pro & I dont what to do.. is there anything I can do? Do I have to buy logic pro all over again? Or is there a way I can get my logic pro 9 working again? damn!
  10. Boyd01 macrumors 68040


    Feb 21, 2012
    New Jersey Pine Barrens
    You must be on a very old Power PC version of Logic that requires "Rosetta". Support for these programs was dropped in 10.7. I don't think there is any way to make these programs work anymore, even if you had the original disks. I think you would either need to revert back to 10.6 or buy a new(er) version of Logic.

    You may find that other programs also don't work under 10.8 for the same reason. If you look in your Applications folder, any incompatible programs will have a circle and slash superimposed over their icons.
  11. dreyes macrumors newbie

    Oct 6, 2013
    Problems with Logic Pro 9.1.8 and OSX Mountain Lion 10.8.5


    I upgraded to OSX Lion 10.8.5 yesterday and since, Logic Pro doesn't recognized such things as Altiverb 6, General MIDI Module or MachFive 2 ("validation blocked")... I have some messages as:

    for MachFive2:
    auvaltool(1030,0xacd7fa28) malloc: *** error for object 0xf1f000: pointer being freed was not allocated
    *** set a breakpoint in malloc_error_break to debug
    validation result: validation bloquée

    for Altiverb:
    Test MIDI
    ERROR: -2147450878 IN CALL MusicDeviceSendMIDI

    (and others)
    Problems in Audio Unit section...

    What can I do?

    Help :)

Share This Page