Logic Pro 9 and Yosemite

Discussion in 'OS X Yosemite (10.10)' started by thomasaiwilcox, Jul 25, 2014.

  1. thomasaiwilcox macrumors newbie

    Joined:
    Jul 25, 2014
    #1
    I have been searching for confirmation that Logic pro 9 is compatible with Yosemite since its announcement but have never found confirmation that it worked.

    As I public beta member I can now confirm that it is compatible from my basic tests. I hope this information will be useful to other logic pro 9 users that are apprehensive to upgrade to Yosemite.
     
  2. AkuskaUK, Jul 25, 2014
    Last edited: Jul 25, 2014

    AkuskaUK macrumors 6502

    AkuskaUK

    Joined:
    Mar 18, 2011
    Location:
    Shanklin, Isle Of Wight
    #2
    Since i stupidly decided to transfer my iTunes library over to Yosemite and i can't use it now with Mavericks (different iTunes versions) I am now contemplating just installing 10.10 as my main operating system. I run Logic as working as an Audio Engineer so i will let you know how it works with that?

    ADDED:

    - I can confirm that my DigiDesign mBox 2 Pro works well with Avids latest drivers.
    - Logic X works acceptably.
    - Installed and bounced down using 58 tracks, using over 20 AU's... works perfectly!
     
  3. VermProject, Jul 30, 2014
    Last edited: Jul 30, 2014

    VermProject macrumors newbie

    Joined:
    Jul 30, 2014
    #3
    I'm in the middle of putting Logic Pro 9 on my Yosemite Beta 1 iMac. The first time, it downloaded the 2GB essential instruments etc,... And when it was done, it prompted me for my password so that Logic Pro could make changes to my system.

    Then all went quiet. Logic Pro didn't come up, and didn't appear to do anything. So I restarted it and it began downloading the 2GB essential stuff again.

    Does anyone know if I should do something to clean up temporary broken downloads, or transfer from my Mavericks system to alleviate this repeating download?

    When I started downloading the App from the App store, I changed my mind and cancelled it, so that I could simply copy the .App from my Mavericks box instead. Now there are two LP icons in my Launch Pad; one working, the other seemingly mid-download, but stuck. Maybe that has something to do with it.
    ------------
    The second attempt failed with a download failure. What I'm doing now is SuperDupering my Mavericks setup over to my USB3 disk, and I'm going to restart from that, and upgrade it in-place to Yosemite.
     

Share This Page