Logic Pro, presonus w/guitar problem... unwanted delay

Discussion in 'Mac Apps and Mac App Store' started by pale9, Aug 13, 2009.

  1. pale9 macrumors regular

    pale9

    #1
    hello,

    i have a presonus firebox, a guitar hooked up to input 1, and LP9. input is firebox, output is built in output.

    when i select a track and enable it with I or R button so i can monitor the sound before i actually recording i get a very noticeable delay between touching the strings and hearing the sound. sometimes very brief, sometimes half a second? cant figure out why this is happening.

    this problem never appears when using garage band.

    any ideas?
     
  2. kasakka macrumors 68000

    Joined:
    Oct 25, 2008
    #2
    It's called latency. Set the Presonus' buffer lower in Logic Pro's settings. If you start getting clicks, cracks or pops then it's set too low and needs to be raised.
     
  3. pale9 thread starter macrumors regular

    pale9

    #3
    where exactly would that setting be?... thanks
     
  4. pale9 thread starter macrumors regular

    pale9

    #4
    now both garageband and logic pro hand while starting

    garageband now initializes forever and logic pro either hangs when loading midi drivers or comes with a messages that there is a problem with midi and i have to reboot the machine and restart logic.

    in either case, even a force quit usually DOES NOT WORK.

    what is going on here.???
     
  5. kasakka macrumors 68000

    Joined:
    Oct 25, 2008
    #5
    It's usually called buffer or latency and it may be shown in buffer size or latency in ms. Found in the same place where you select your audio interface for audio input/output.
     
  6. pale9 thread starter macrumors regular

    pale9

    #6
    found the problem

    ok the main culprit with the hang problem and delay problem was one or more audio plug-ins that i installed. i think it was either a D16, Camel audio and/or Ohm Force.

    if you ever have this problem you have to check all over for any and all parts of a audio plug-in order to totally remove it.

    hd/library/audio
    hd/lirbary/application support
    user/library/audio
    user/library/application support
    applications
    hd/library/preferences
    user/library/preferences

    think thats it.
     

Share This Page