Logic X 10.2

Discussion in 'OS X El Capitan (10.11)' started by ErikGrim, Aug 26, 2015.

  1. ErikGrim macrumors 68040

    ErikGrim

    Joined:
    Jun 20, 2003
    Location:
    Brisbane, Australia
    #1
    Not working. Alchemy thread crashing.

    Code:
    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0   com.apple.music.apps.MAAlchemy    0x0000000108bcefca AlchemySharedLib2::AlchemyPreset::setSampleRate(float) + 10
    1   com.apple.music.apps.MAAlchemy    0x0000000108e0d78c AlchemySharedLib2::AlchemyPlugin::reset(float) + 60
    2   com.apple.music.apps.MAAlchemy    0x0000000108e0be39 AlchemySharedLib2::AlchemyPlugin::AlchemyPlugin(AlchemySharedLib2::AlchemyHostInterface*) + 6521
    3   com.apple.music.apps.MAAlchemy    0x00000001090648ef CamelAudioAU2::AlchemyPluginHostWrapper::createPlugin() + 47
    4   com.apple.music.apps.MAAlchemy    0x0000000108dea38f CamelAudioAU2::AlchemyPluginAU::AlchemyPluginAU() + 271
    5   com.apple.music.apps.MAAlchemy    0x0000000108dea25c CreateA2Instance + 28
    6   com.apple.music.apps.MAAudioEngine    0x0000000106e91a16 MAAEGetPlugInDefaultTagForPlugInManager + 54
    7   com.apple.music.apps.MAAudioEngine    0x0000000106eeb68b MAAEPlugInManager_ScanForNewPlugIns(long, bool) + 171
    8   com.apple.music.apps.MAAudioEngine    0x0000000106eebc81 MAAEPlugInManager_DoStartupTasks + 81
    9   com.apple.music.apps.MAAudioEngine    0x0000000106e6cb88 MD::Init(int, CDRV_ALPRunMode_t) + 7624
    10  com.apple.music.apps.MAAudioEngine    0x0000000106e7db8c MDCA::Init(int, CDRV_ALPRunMode_t) + 7900
    11  com.apple.logic10                 0x0000000103b72922 0x103abb000 + 751906
    12  com.apple.logic10                 0x0000000103b74683 0x103abb000 + 759427
    13  com.apple.logic10                 0x0000000103f76e56 0x103abb000 + 4963926
    14  com.apple.logic10                 0x0000000103ca4575 0x103abb000 + 2004341
    15  com.apple.logic10                 0x0000000104181e22 0x103abb000 + 7106082
    16  com.apple.logic10                 0x000000010417a77a 0x103abb000 + 7075706
    17  com.apple.CoreFoundation         0x00007fff8a2776bc __CFNOTIFICATIONCENTER_IS_CALLING_OUT_TO_AN_OBSERVER__ + 12
    18  com.apple.CoreFoundation         0x00007fff8a27762f ___CFXRegistrationPost_block_invoke + 63
    19  com.apple.CoreFoundation         0x00007fff8a276cf7 _CFXRegistrationPost + 407
    20  com.apple.CoreFoundation         0x00007fff8a276a62 ___CFXNotificationPost_block_invoke + 50
    21  com.apple.CoreFoundation         0x00007fff8a270cf2 -[_CFXNotificationRegistrar find:object:observer:enumerator:] + 1922
    22  com.apple.CoreFoundation         0x00007fff8a15f845 _CFXNotificationPost + 693
    
     
  2. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
  3. ErikGrim thread starter macrumors 68040

    ErikGrim

    Joined:
    Jun 20, 2003
    Location:
    Brisbane, Australia
    #3
    It gets even weirder. It works on a fresh account, but not if I nuke all logic preferences and both Audio folders on my regular account.
     
  4. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #4
    why'd you start a separate thread? we were discussing this in the 'working and non working apps' one. anyway, posted another idea there....
     

Share This Page