Login failure problem (long)

Discussion in 'macOS' started by C. Alan, Feb 3, 2011.

  1. C. Alan, Feb 3, 2011
    Last edited: Feb 3, 2011

    C. Alan macrumors 6502

    Joined:
    Jan 23, 2009
    #1
    I cannot login to my my '09 Mac Pro. Ive tried restoring the system from my time machine backup, restoring my system from the back DVD that came with my Mac Pror, fixing the disk permissions, and performing disk repairs. None of these thing have allowed me to login.

    Here is some more background

    My Mac Pro has three diffent HD volumes: a 40G SSD boot volume, a 640g Seagate HD that has my var/usr diretories, and applications directory on it, and a 150g Final Cut Scratch drive that has my Final Cut Express projects on it. The SSD drive and the Seagate HD both get backed up via time machine to a 2TB external Fire Wire drive. I am running Snow Leopard on this machine. There are only two accounts on the machine, mine, and my wifes.

    My Mac Pro normally stays on all the time, this is mainly to support Itunes and my Apple TV. The only times it gets rebooted is when I have to do an update that requires one.

    So yesterday I woke my Mac Pro up, and discovered that my wall paper image was gone. I thought this was kind of puzzling, so then I quick switched over to my wife's account on the machine. It was there I notieced that a mail window that she had open contained nothing but NULL characters. This lead me to reboot the machine, and that turned out to be a mistake. Now, after a reboot, the login screen comes up, and it will accept my password, then I see a the blue login bar, and an error message comes up telling me that it cannot login at this time, and that an error occured upon login. Both accounts on the machine give the same login behavior, even after mutiple attemps to restore the system.

    It will boot onto the backup DVD that came with the machine. I can run terminals from here, and I know just enough bash shell commands to be dangerous. From the terminal, I did discover that the name of my 640g HD that contains the var/usr directories had been changed. I think my 22 month old son who loves anything with buttons may have been responsible for this.

    I suspect that somehow the connection between the Operating system on the SSD drive and the user information on the 640g HD has somehow been broken. When I ran the Disk Utility tools, errors were found on the 640g HD.

    Would changing the name of the volume that contains the var/usr diretories screw up the login process? Where can I find the login logs so I can try to figure out what is going on? Could I use the terminal in single user mode to create a new admin account, so I could at least get the machine to login to the GUI?

    I can boot the machine into single user mode, and I still remember some of my VI from college, so I think I can browse logs. I also should note that when I did my system restores, it only restored the files on my SSD drive.

    Thanks in advance,
    C. Alan
     
  2. C. Alan thread starter macrumors 6502

    Joined:
    Jan 23, 2009
    #2
    Problem solved

    Ok I fixed it.

    For the purposes of helping someone else in the future, I will document how I did it.

    The problem was that the volume that the had the user directory on it had accidentally been renamed. I think the culprit responsible for that was my almost 2 year old son. So when the computer went to boot up, in the user setup it was looking in the wrong place for user information. Thus, the login error.

    There are two ways to fix this (btw, this works for OSX 10.6):

    The first way...
    1. If you know what the name of the volume is supposed to be, you can boot the computer using the back DVD, and let the install progress to the point to where you find the current Volume name that has your user folder in it. Write down the current volume name, and then cancel the install.

    2. Then go to the utility menu, and open a terminal session. you then need to type in:
    Code:
    diskutil rename [I]"current volume name"  "old volume name"[/I]
    In my case, my current volume name that my user directory was in was called "ALSKJD", and the old Volume name was "Macintosh HD". After I ran this command, it reset the name of the volume my user directory back to Machintosh HD. Just as a note. If you user volume name had spaces in it, you will need to use quotes around the name.

    Reboot the machine, and hopefully, all will be well.

    Now the Second Way.
    1. Now suppose you really don't remember what the volume name was? This was the problem I had, and because I had no user files on the boot drive, I couldn't boot the computer at all. Well there is a way to creating a new Admin account on a mac without booting into the operating system. As described above, you need to boot the computer with a backup DVD, and open a terminal session.

    2. Then type in:
    Code:
    rm /var/db/.AppleSetupDone
    Then reboot the machine. You should see the intro video and be guided through setting up an account on the machine. Then you can use this new login to boot into OSX, and fix the broken user paths using the preference panel.

    What the above command does is to erase a file that OSX places in the db directory after you first setup your machine. Erasing this file (thats what 'rm' does) will make OSX assume that the computer is being booted for the first time, and it goes through the routine of setting up an admin account.
     

Share This Page