Login issues on OS X 10.6 (some comps allow users to log while others dont)

Discussion in 'Mac OS X Server, Xserve, and Networking' started by jamanyar, Oct 20, 2009.

  1. jamanyar macrumors newbie

    Joined:
    Oct 20, 2009
    #1
    Hi,

    I am a teacher at a special needs school and have been using mac for a number of years developing multimedia profiles for our students. In the hope of developing our system i thought it would be advantageous to invest in a Mac Server setup. My colleague and i have had a very sharp and steep learning curve, but we looked like we were making headway until this annoying problem.

    I have setup OS X 10.6 on a new 20" iMac. I have DNS up and running normally (used terminal to confirm 'nslookup changeip...), I have OD configured and working, i have bound the computers on the network to the server and all seems fine looking at both workgroup manager and server admin.

    I have two of the four computers allowing all users in the different user groups to log on with all their permissions, share points and preferences correctly configured. However, with the two new computers that i have 'binded' with the server (showing as bound to the server in workgroup manger) they simply wont allow any user to log on. It states an error has occurred and the user is unable to log on at this time. If i log as a local user to one of those computers i can navigate to the server using the finder and connect as any of the users and gain access to the their folders.

    Now we did notice that the when using computer inspector (workgroup manager) that the two new computers bound had the same ID number (150001, 150006) as the other computers that were working ok. thinking this was not good we manually changed them to unique numbers. We had hoped that this would solve the problem because we had similar problem with user ID numbers and workgroup numbers begin the same, but alas no such luck.

    We have 'unbind' and 'bind' the computer a number of time but no change with the login problem.

    Please if anyone can help i would greatly appreciate it.

    Cheers for reading this far!!

    Jawied
     
  2. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
  3. jamanyar thread starter macrumors newbie

    Joined:
    Oct 20, 2009
    #3
    Hey,

    Are they are specific logs I should be looking at?.

    When we had the issue with the group and user ID's begin given the same number, one of the Logs (can't remember which one) pointed to the user not being able to find the user home folder. With this problem we have opened every log that is available to see if we can find anything that may indicate to what the issue may be, but we've not found anything.

    Is there anything that we can do to confirm that the computers have indeed correctly been 'Bind' with the server other that it being displayed in workgroup manger in the computer list or with using open directory utility on the client machine?

    We also tried binding a MacBookPro to the server and again the same issue of the users not being able to Log.

    It seems that with every new computer being added, the server for some reason does not allow existing users to log on, yet over the network they are allowed access to their folders when they authenticate after clicking on 'connect to'.

    I may be a little hopeful but i will create new users to the network and try to see if they log on.

    J.
     
  4. jamanyar thread starter macrumors newbie

    Joined:
    Oct 20, 2009
    #4
    Hey,

    Just checked the system log in server admin and came across this error after having tried to log from one of the new computers on the network


    Oct 21 07:12:37 labserver1 Workgroup Manager[983]: *** -[WPWebServices createServicesInformationRecordInLocalNodeWithSession:]: couldn't create the Computer record in /Local/Default. Reason: Unable to create record ServicesInformation in /Local/Default.

    Any ideas anyone.

    Thanks

    J
     
  5. jamanyar thread starter macrumors newbie

    Joined:
    Oct 20, 2009
    #5
    I'v decided to try and restore the server from Timemachine as the other 'good' computers have started to display login issues.

    At the very least it gives me a chance to learn how to use Timemachine and review it's reliability as a backup solution.

    J.
     
  6. bradleys83 macrumors newbie

    Joined:
    Oct 22, 2009
    #6
    Just one quick question - we're the client computers that you have bound to the server installed from any kind of template or 'Golden Master' disk image?

    I've bumped into this a number of times before (have about 550 macs bound to MSAD and OD) one part of the issue was the use of a single disk image restored onto multiple computers - security ID's, kerberos tickets and things all identical which the server is never going to agree with.

    Other thing to check is make sure you have done an authenticated bind with your clients and not an anonymous one (It should ask you to enter your diradmin username and password to complete the binding process)

    The error log snippet looks a little strange - things involving Mac OS X server should be trying to read/write /LDAP/127.0.0.1 and not /Local/Default

    Sorry if all the above was utterly useless - theres a bunch of reasons things like this happen (about 6 or 7 different ones are covered in the OSX deployment and Directory Services exams)
     

Share This Page