logitech g5 mouse and macbook

Salteh

macrumors member
Original poster
Nov 28, 2005
37
0
ive tried installing my logitech g5 mouse on my macbook but im having alot of problems with it.
i couldnt find any software for it, as i wanted to change the acceleration on the mouse because when i first plugged it in it was unusable.
i downloaded some software from logitechs site but i dont think it was right, and now my mouses buttons dont work but im not sure how to get rid of it.
can anyone help me? the mouse tracks now but no buttons work
 

Salteh

macrumors member
Original poster
Nov 28, 2005
37
0
ive tried that and it doesnt make any difference, im getting bored of trying to make it work.
i have "logitech control center" 2.0 installed, how do i go about uninstalling it?
it doesnt appear in my applications folder, only appears at the bottom of system preferences. sorry im a mac noob, the g5 is from my old pc.
i might buy myself a new mouse as i need a keyboard, any recommendations that defo work with the macbook?
 

Obsidian6

macrumors 6502a
Apr 29, 2006
682
2
Laguna Niguel, CA
no no no it will work, trust me.

i have the mx518 ( predecessor to the g5 ) on my powermac g5 a home and it works great!

what you need to do is uninstall the logitech stuff. just download ( or re-open ) the installation pkg and select "uninstall" it will remove all of that stuff, then do a reboot ( just to be safe, not entirely necessary ) and THEN re-map your g5 mouse with usb-overdrive.

it will work, i guarantee it.
 

Salteh

macrumors member
Original poster
Nov 28, 2005
37
0
right i got it working now, only trouble im having is getting the extra buttons mapped.
on my pc i had the left hand side button set to open new tabs from links in firefox, and the scroll wheel that moves left to right aswell i had set to back/forward in firefox.
any idea how i do this? ive tried loads of different buttons on usb overdrive mapping back etc to them and nothing works