Logitech G5 mouse: skippy tracking?

Discussion in 'Mac Accessories' started by nagromme, Jul 17, 2008.

  1. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #1
    I like this mouse, but may return it: for photoshop retouching it's maddening! I'm wondering if I got a defective unit, but I doubt it. Speed feels fine, but it gets erratic.

    If anyone has one, maybe you could try this (in Mac OS X): with DPI set to the middle ("normal feel") option, try to move the arrow in small circles, about the size of a dime on the screen. Slowly. Gradually get faster. Does it do any little movements that aren't what you wanted?

    Mine skips every few seconds (darting ahead a few mm suddenly) instead of moving smoothly. Enough to ruin any kind of drawing or retouching, which my Apple mouse handles fine. (It's not so noticeable for broad UI actions, which is why I didn't catch on at first.)

    I retested against my bluetooth Mighty Mouse, and the Mighty Mouse does NOT skip in that way. I also tried multiple surfaces. Mighty Mouse is always fine, G5 is not. (It's not just a different "feel:" the mouse jumps erratically, several pixels at a time--and only sometimes..)

    I also tested my 10-year old Intellimouse--it doesn't skip either. And I tried different mouse speeds in System Prefs: the G5 skips at anything from the slowest speed to the fastest. (I also tried the other DPI settings on the mouse--they skip too, but it's harder to test since those speeds are so far from normal mouse usage.)

    Anyone else see this?

    I got a gaming-grade laser mouse for precision, but if it acts like this, then I'll have to return it. Maybe it's only OK in Windows?

    TIA
     
  2. nagromme thread starter macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #2
    Yep, the G5 skips. Back to the store it goes.

    Follow-up info from my research:

    The G5 does indeed have a known history of skipping exactly like this. Yes, the new model (blue, 2 thumb buttons) that I have. Not sure about the older one.

    Not good for Photoshop, not good for Strogg railguns!

    http://www.google.com/search?client=safari&rls=en-us&q=logitech+g5+skips&ie=UTF-8&oe=UTF-8

    There's a firmware update that supposedly fixes this, but it requires the Windows-only SetPoint driver, and all I have for Windows these days is VMWare Fusion--which indirectly relies on your Mac mouse driver so it can't use SetPoint. (I tried. SetPoint installed but it couldn't see the mouse. All it did was give my anti-malware apps a giant Holstein cow.)

    I could just take it to a friend's Windows box, BUT I'd have to install Logitech drivers on their system. I would not be willing to mess with someone else's OS and registry in that way :eek: And they'd be remiss to let me.

    So yes, in a sense, this is a Mac-only issue (and to be fair, Logitech doesn't claim Mac compatibility with this mouse).

    So, back to the store it goes :( I thought I had found the ONE decent gaming mouse with enough buttons for my needs. It seems none exist that will work with Mac. The G9 is still a possibility, but I don't like the shape and I won't risk it unless I can find a good sale price locally (for easy returns).

    I wish Logitech would just sell new mice WITH the latest firmware! I have hopes of buying this same mouse someday and getting one that doesn't skip. Maybe.

    Too bad--without the skipping, this "unsupported" mouse would be a GREAT Mac mouse right out of the box!

    (PS, I notice Logitech sells replacement teflon feet for $2 a set. Not bad.)
     
  3. Dae macrumors regular

    Dae

    Joined:
    Apr 30, 2009
    #3
    Thank you very much for the information! I have exactly the same issue with G5 on Macbook Pro.
     

Share This Page