Logitech K760 wireless keyboard and Windows 7

Discussion in 'Windows, Linux & Others on the Mac' started by 0verflow, Nov 16, 2012.

  1. 0verflow macrumors newbie

    Joined:
    Nov 16, 2012
    #1
    I recently bought a Logitech K760 wireless keyboard and so far it's been working great, except for when I pair it in bootcamp Windows 7.

    Initially it worked fine, until my next bootup in Windows. It would not pair at all, even when removing the device and trying to add it again. After some testing I figured a way to pair the device again, by first removing/uninstalling it, then finding it under "Add devices" and going to properties then doing a check on "Drivers for keyboard, mice, etc (HID)". That now seems to be the only way to install the keyboard again (regular connecting procedures don't work).

    The problem is that sometimes (over 50% of the times) I reboot into Windows after turning the computer off or being in OS X, I need to reinstall the keyboard again. Sometimes it just works and I can press the assigned key profile on the keyboard (it has 3 profiles) and it will work like it should, but mostly it won't pair and I'll have to repair them again. Sometimes the keyboard will just disconnect under use too and start lagging the computer for some reason, and I'll have to reinstall to fix it which is quite annoying.

    So I was wondering if anyone has a fix/solution at hand? I think I've read about someone experiencing the same on a regular Apple Bluetooth keyboard, and their "fix" had been to connect through a bluetooth USB stick as it used a generic bluetooth driver. Perhaps the Apple bootcamp driver is the problem? Anyways I should say I'm using a 15" MacBook Pro Mid-2009 model. Thanks in advance for help.
     
  2. 0verflow thread starter macrumors newbie

    Joined:
    Nov 16, 2012
    #2
    Bump? Please anyone with experience with wireless Mac keyboards and bootcamp.
     
  3. abbaswb macrumors newbie

    Joined:
    Jan 12, 2013
    #3
    thanks bro i made a account to thank you :) because of i finnaly made the keybord work and i have the same problem imac and bootcamp have a good life my friend :D
     

Share This Page