Logitech K811 Keyboard Doesn't Charge

Discussion in 'Mac Accessories' started by jagooch, Mar 14, 2014.

  1. jagooch macrumors regular

    jagooch

    Joined:
    Jul 17, 2009
    Location:
    Denver, co
    #1
    I received my Logitech K811 keyboard from logitech 2 days ago I happily plugged it into my USB charger at my desk , connected it, and started using it. I finally decided to unplug it and start using it around the house, but it turned off the moment I unplugged it, and turning it off and then back on doesn't elicit any response.

    I've tried plugging it into my 4-port device charger while on and while off. It lights up when I plug it in and it's on, but does nothing if plugged in and off. What I was expected was to see the battery led pulse to show that it's charging.

    For emphasis , it works great when plugged into USB hub or charger, but is completely dead when not plugged in. There is no activity( i.e. nothing lights up and it doesn't connect to my Macbook ) when it isn't plugged in.

    Is there anything that I can do to try and fix it, or should I just return it and wait for a replacement?

    I'm in denial because I like the keyboard so much, that I'd love to have it working today than wait to RMA it and wait for a replacement to be mailed to me.
     
  2. John Kotches macrumors 6502

    Joined:
    Jan 19, 2010
    Location:
    Troy, IL (STL Area)
    #2
    Sounds like a defective keyboard to me.

    I love my k811... Bought one for work and one for home.
     
  3. jagooch thread starter macrumors regular

    jagooch

    Joined:
    Jul 17, 2009
    Location:
    Denver, co
    #3
    I ordered a replacement and I'm sending the defective one back. I like the keyboard even though the battery is not repaceable and it doesn't tilt up.
     
  4. John Kotches macrumors 6502

    Joined:
    Jan 19, 2010
    Location:
    Troy, IL (STL Area)
    #4
    I prefer that myself.
     

Share This Page