Logitech mouse in Leopard 10.5.6 problem

Discussion in 'macOS' started by kirkbross, Mar 21, 2009.

  1. kirkbross macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #1
    I just bought a Logitech MX Revolution wireless mouse for my Mac Pro running Leopard 10.5.6. The mouse functions, but the Control Center application (LCC) does not recognize the mouse, hence I can't program the buttons. I've have tried every combination of uninstalling and re-installing with the same results. Here's what I get when I run the LCC from System Preferences:

    [​IMG]

    I own a license for Steermouse, but you'd think for $80 they'd get the drivers working. Anyone have the same experience and find a solution? I also have a ticket in with Logitech, but I keep getting broad spectrum form responses.
     
  2. BobZune macrumors 6502a

    Joined:
    Oct 26, 2007
    Location:
    USA
    #2
    Long shot answer: If you haven't already tried it, plug the USB receiver directly into the machine's USB port (not the keyboard/monitor USB ports) first time.

    You may be better off with SteerMouse - this is what I use for the same mouse model you have. I used the LogiTech drivers for a short time, but didn't find them as stable/satisfactory as SteerMouse. Most other people who have that mouse seem to be using the SteerMouse also.
     
  3. SmurfBoxMasta macrumors 65816

    SmurfBoxMasta

    Joined:
    Nov 24, 2005
    Location:
    I'm only really here at night.
    #3
    Although LT's hardware is nice, their software for macs blows..... I have tried it on several different macs running panther, tiger & leopard, and have never been able to use it without problems of 1 kind or another.....
     

Share This Page