Logitech Mouse problems

Discussion in 'macOS' started by swac, Oct 29, 2007.

  1. swac macrumors newbie

    Joined:
    Oct 25, 2007
    #1
    I've used my Logitech MX-400 laser mouse for a few months now, and I've been able to take advantage of all its special features (tilt wheel, side buttons). I recently installed Steer Mouse just to try it out and then tried to get rid of it. However, the Logitech Control Center prefpane no longer detects my mouse. So I'm stuck with using my mouse without its extra buttons. I've tried reinstalling the Logitech Control Center and it still doesn't detect my mouse. Tried both USB ports as well. I just installed Leopard and the problem remains. What should I do?
     
  2. emptyCup macrumors 65816

    emptyCup

    Joined:
    Jan 5, 2005
    #2
    Logitech installs Unsanity's Application Extender (APE) which hacks the system in ways Apple specifically warns against. This one application (APE) has been traced back to being the sole cause of the Blue Screen of Death problems some people have reported when trying to upgrade. You are lucky. Have you tried going to Logitech? That is where I would look for a fix.
     
  3. QCassidy352 macrumors G3

    QCassidy352

    Joined:
    Mar 20, 2003
    Location:
    Bay Area
    #3
    I'm guessing steermouse overrode the logitech settings, and you didn't completely get rid of it. Try searching your HD for anything steermouse-related and trash it.

    FWIW, I use steermouse with a logitech MX-518, and it's flawless. Different settings in different apps, use of all 8 buttons, the works. Totally worth every penny.
     
  4. khollister macrumors 6502a

    khollister

    Joined:
    Feb 1, 2003
    Location:
    Orlando, FL
    #4
    USB Overdrive also works great as a Logitech Preference Pane replacement.
     
  5. swac thread starter macrumors newbie

    Joined:
    Oct 25, 2007
    #5
    SteerMouse seems to be a 15-day trial. It doesn't seem to have anything substantially better than Logitech's free software, so I really don't want to buy it.
     

Share This Page