Logitech MX Revolution broke my mouse cursor.

Discussion in 'macOS' started by jaypee68, Sep 11, 2008.

  1. jaypee68 macrumors regular

    Joined:
    Sep 20, 2007
    #1
    I got a new Logitech MX Revolution today, and I plugged in the USB dongle, and turned on the mouse, and everytime I move the mouse, the cursor shoots over to the right hand side of the screen. I thought maybe I was having a conflict with an existing install of the Logitech control center, but it doesn't matter what mouse I plug in, I still have the same problem. i've tried both the mighty mouse, and the other Logitech mouse I have, and I get the same result.

    My mac is totally useless, I can't even navigate enough to turn off USB Overdrive in case that is an issue to. Can some help please? I sit here looking at a useless $2500 paperweight. :-(

    Edit: I have booted into safe mode and removed both USB Overdrive and the Logitech Control Center, and I still have this mouse cursor issue after reboot. But while I'm in safe mode, my mouse works just fine.
     
  2. jaypee68 thread starter macrumors regular

    Joined:
    Sep 20, 2007
    #2
    Well, I figured out my problem. The problem is that I'm a complete idiot, the type of user I can't stand to support, I use acronyms and nicknames like PEBKAC or id10t error. You see, I own an Wacom Intuos 3 6x8 tablet, and when I was installing the mouse, I moved the digipen holder with the pen in it on to the side of the active pad. Well what do you think happens when you do that? A USB mouse and the tablet fight for superiority and the pad wins by homing the cursor to the side of the screen.

    I feel like a total idiot, but just wanted to share this with all of you hoping that some of you would appreciate the humor in this. :rolleyes:
     

Share This Page