Logitech V470 Problems

Discussion in 'Mac Accessories' started by StvRndy, Aug 25, 2008.

  1. StvRndy macrumors member

    Joined:
    May 12, 2008
    #1
    I just recently bought the Logitech V470 to replace my Mighty Mouse. I disappointed of its performance. It always has this jumpy/sluggish feel every time it is not used for awhile and then when you move the mouse you will feel the sluggish movement for like 1-2 seconds. It doesn't feel nice at all. I think this is because of the power saving management?
    Anyone has the same issue? Is there a way to make it on all the time? Battery life is not really a problem for me.

    Another issue I found is that this mouse's middle click must be push very hard and quite long period only it performs the action. Very annoying.

    Need some suggestions from V470 users regarding these issues. Thanks.
     
  2. StvRndy thread starter macrumors member

    Joined:
    May 12, 2008
  3. The Monkey macrumors 6502

    Joined:
    Feb 19, 2006
    #3
    No help here other than to say I feel your pain. I got the 470 the other day and hate it for all the reasons you describe.
     
  4. erikistired macrumors 6502

    erikistired

    Joined:
    Apr 21, 2006
    Location:
    (770)
  5. StvRndy thread starter macrumors member

    Joined:
    May 12, 2008
    #5
    Yeah I have tried new rechargeable batteries. Still was the same.
    Then I went to the shop to ask a replacement. The new unit however still has this delay issue. I think all is the same. Moreover this new unit has another new issue where the left click is harder than the right click.

    Seems that Logitech has poor quality of their mouse products.
     
  6. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #6
    Logitech has excellent warranty; call them up, they will tell you to send part of the mice in or a receipt and then they send you a new mouse and you keep what's left of the "broken" one.
     
  7. gigadigit macrumors member

    Joined:
    Apr 24, 2009
    #7
    I just got this mouse too and I can feel the lag. I bought this to replace the MS presenter 8000, and i think MS one is smoother; but with that one, I can't make it to move fast.

     
  8. rgarjr macrumors 603

    rgarjr

    Joined:
    Apr 2, 2009
    Location:
    Southern Calif
    #8
    U do know that this thread is almost a year old.
     

Share This Page