Logitech VX Revolution not working!!

Discussion in 'Mac Accessories' started by iFool, Aug 16, 2008.

  1. iFool macrumors member

    Joined:
    Feb 5, 2008
    #1
    Hi,

    I just got back from France, where I bought a Logitech Vx Revolution, I plugged it in to My PC (my Mac is not connected to Anything so I thought I nmight as well use the PC.) When I turned it on, it simply didn't work, I installed the software and updated it, it didn't wordk, I used the Logitech Connect Utility, It didn't work :(

    Any suggestions, would the fact it is from france make a difference, the First langauge on the box and software is english.

    Thanks!
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    When you say it isn't working, can you be more specific? Does it not connect at all? Any error messages? Does your PC detect the mouse?

    Did you check the batteries? Turn it on? Sync it with the PC?

    The language should have no effect.
     
  3. iFool thread starter macrumors member

    Joined:
    Feb 5, 2008
    #3
    The PC doesn't detect it at all, the battery is fine, it came with the mouse and the battery meter is full. I have also tried all USB ports.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Did you try it with the Mac to make sure it's not a defective mouse or receiver?
     
  5. iFool thread starter macrumors member

    Joined:
    Feb 5, 2008
    #5
    I just tried it on my Mac( with no software) and it doesnt work.
     

Share This Page