Logitech VX Revolution Scroll Issues

Discussion in 'Mac Accessories' started by digitaldave, Nov 24, 2006.

  1. digitaldave macrumors regular


    Apr 6, 2006
    I've just bought a Logitech VX revolution mouse and got it all set up fine, apart form the scrolling. If I have the ratchet mode enabled, it scrolls very slowly, even if I have the scroll speed set to the fastest setting :(. I can get faster scrolling by using the free wheel mode, but this doesn't seem to give much of an improvement in World of Warcraft :(. Has anyone else managed to solve this? Annoyingly, it works much better on my PC (although there are other issues with that ;)).


  2. HazChem macrumors regular


    Oct 26, 2006
    Yeah, I noticed this too in Safari although it seems to depend on the application. The only app I have found where the scroll is working well is in Word.

    Very annoying to say the least.
  3. Sesshi macrumors G3


    Jun 3, 2006
    One Nation Under Gordon
    Not really noticed a speed problem. I can 'flip' the wheel and it'll whizz up and down in either mode on both MBP and Pro. I hate the free mode on the VX/MX as the inertia of the wheel means it overshoots where I'm aiming to be.
  4. NewtotheMac macrumors newbie

    Feb 27, 2008
    the great state of Denial
    I am having a similar problem

    I have the Logitech VX as well and love it except for.... When I change the scroll speed in the settings it does not work on all pages unless I bring up the settings page click on the title bar of it (to select it), then minimize it and then the speed works until I go to a new page then it goes back to being slow again. Any suggestions? Thanks in advance :)
  5. mediumofmeaning macrumors member

    Sep 20, 2007
    yeah, the vx has scrolling issues. i just recently posted a thread on a similar issue. try to open a file from safari and dig through the 3-column view, scroll up and down. dont work. happens on a couple of different dialogues. i was in contact with logitech support about reporting the bug, but they just seemed to ignore me.
  6. NewtotheMac macrumors newbie

    Feb 27, 2008
    the great state of Denial
    A way around it!

    I just programed my logitech side buttons to scroll up and down, so now instead of using the wheel and having to roll it multiple times, I just press and hold the thumb side buttons to scroll with. It works great. And as an added bonus, you can make the speed accelerate the longer you hold the button down which is very useful for long web pages etc.:)
  7. EdbBob macrumors member

    Oct 25, 2008
    You could try the "SteerMouse" driver (not on Apples site anymore, google it). It works perfectly with a Logitech G5. Logitech are far better at making hardware than software... ;)
  8. rbownes macrumors newbie

    Nov 12, 2008
    How to fix scroll problem

    system preferences....logitech control center....instead of global settings....go down and select "Safari". then pick the scroll wheel and adjust the speed and acceleration. This worked for me.
  9. powz macrumors regular

    Apr 24, 2007
    Works great! Almost returned my VX Revolution because of this problem. Thanks for sharing.

  10. seangreensean macrumors newbie

    May 23, 2009
    you nearly solved it!!!

    Thanks for the advice to alter the "precision scroll speed" in the Logitec control centre in system preferences... However it didn't work for me at first. I found that altering the 'Safari settings' makes little difference and that its the 'Global settings' that makes the changes in Safari. in particular its the 'acceleration' setting rather than the speed setting that changes the scroll speed. :p
  11. pellets007 macrumors 6502a


    Jan 28, 2009
    New York
    How is the accuracy and smoothness of the pointer on the VX Revolution? I don't mean to hijack, but I was looking into buying one. The only thing is that I have a Logitech mouse that doesn't work as well as I want it to under OS X, despite installing the Control Center and SteerMouse.

Share This Page