Logitech Webcam Pro 9000 HD no mic on mini

Discussion in 'Mac mini' started by bittergeek, Nov 15, 2010.

  1. bittergeek macrumors newbie

    Joined:
    Nov 15, 2010
    #1
    I got the mini a few weeks ago and have been struggling to make the Pro 9000 HD work properly on it.

    The camera always works. The problem is the mic which works only intermittently one out of ten times maybe.

    I did some googling and found other people having similar issues.

    So, I reckon this webcam just doesn't work properly with mini.

    However, I found that it always works after reseting PRAM. I don't want to do that everytime I power on the mini (not sure if that would do any physicial damage to the ram either).

    Does this tell you experienced users anything I don't see? Any advice?

    Thanks a lot!
     
  2. vbob, Jan 13, 2011
    Last edited: Jan 13, 2011

    vbob macrumors newbie

    Joined:
    Jan 4, 2011
    #2
    I am on a mac pro 2009 and use the "Logitech Pro 9000" (PC Version) usb Camera without a problem for about a year.
    Today I tried to do a skype video call again with one of my friends and discovered that the microphone didn't work at all on my OSX Snow Leopard 10.6.5.

    First I checked the preferences on my mac osx. No good luck there.

    I tried to check the camera on Windows / Virtual Machine (Fussion 3) and discovered that the microphone didn't work at windows neither. (I had a hope that maybe something was "Stuck" for the camera and that if windows with the native windows drivers of the camera could "see" the camera in it's nature environment, it should be un-stucked or something...!!! Lool..!!!!) (If you find my "windows seek for help" behavior strange read bellow for an old linux problem I had once, when a USB HDD Stacked and couldn't mount to my linux system because it was not properly unmounted on windows (unmount on windows = "Safely Eject Hardware"). After a lot of search for the HDD issue solution on many linux forums, I found that I had to mount and unmount the usb hdd on windows. Then go on linux and mount as usually the HDD. The problem on linux mounting an unproperly unmounted USB HDD from windows solved and I thought that some kind of "same logic" could solve the problem for the mic of the logitech camera too...Looll...but I was almost wrong...!!!!) :p
    I Played somehow with the properties (on windows) for the camera microphone and found that it was muted. I un-muted it and at the properties panel I saw that the green bars was moving (indicating that the device was receiving sounds through the logitech's mic. I opened on windows the program of the logitech to record a video with sound and the mic was not enabled.
    That was the 1st indication that the problem is software problem and not hardware problem (the mic is still working) and somehow it get muted...!!!!?

    I even reseted PRAM on my mac pro by rebooting my machine and pressing the Command+Option+P+R until the white screen appears (see the apple way of doing reset PRAM on your model of mac and for more details).
    The reset of PRAM on my mac pro didn't work.

    I Googled it more and found that if you go to "Applications/Utilities/" and Run the "Audio Midi Setup.app" in the list of the devices you will find a device "unknown USB Audio Device" (it will have the symbol/icon of the mic). If you select it and check at the right of the application GUI you will discover that for some strange reason the mic is muted. Un-mute it and everything will play normally...!!!!


    Now the device have the mic again enabled (un-muted).
    I really don't know why this suddenly happened, but by doing what I described earlier, should solve your "mic problem". It worked for me. The problem of the camera is not because you have a mac mini. Mac's usually don't have problems with the devices. If the drivers exist for mac's, usually it recognize them automatically in 2-3 seconds. It must be a logitech's driver bug or something. (I was using this camera for a almost a year before the mic problem occurred. Nothing was changed in my mac devices from the time it worked until today that it stopped working suddenly)
    I hope my info helps you solve your problem with the camera.
    Cheers...!!! :)
     
  3. fseminario macrumors newbie

    Joined:
    May 25, 2012
    #3
    The above post actually guided me to get it working.

    Once in the Midi utility, locate the unknown USB device with mic icon next to it and change the frequency range to the lowest option. Then try testing it again. This worked for me. I think it doesnt work on anything above 16000.
     
  4. vbob, Aug 18, 2012
    Last edited: Sep 8, 2012

    vbob macrumors newbie

    Joined:
    Jan 4, 2011
    #4
    In the midi utility mute & unmute, degreace the khz and set them again in 44khz after every restart. The microphone works again.
    In lion sudenly the camera stoped working correctly and i installed drivers (for mac) from another model.
    With the above trick (midi utility) it works in my mac pro with no problem. (only autofocus never worked in mac but for normal usage without "macro" or special focus "close" shots this is not a problem.

    Edit: I just tried the camera in a clean install of mountain lion 10.8 and it works (it automatically recognise it). There is no need to play with midi utility any more (for me).

    Edit: mac osx mountain lion 10.8.1 microphone problem.
    The microphone is not working on mountain lion. :-( any ideas anyone?
     
  5. vbob, Sep 8, 2012
    Last edited: Sep 8, 2012

    vbob macrumors newbie

    Joined:
    Jan 4, 2011
    #5
    Ok, here is the most recent info i found out about the Logitech 9000 pro (pc version) on my mac pro.
    A) the camera works on clean install of mountain lion mac os x 10.8.0 and 10.8.1. (default drivers of osx).
    B) the camera's microphone work on clean install of mountain lion mac os x 10.8.0 and 10.8.1.(default drivers of osx). (but we have to run the midi utility and fo the trick of mute/unmute and change the sampling to something else and then put it back to the 44khz).
    C) the problem in my mac pro with the webcam microphone (stopped appearing as "unknown usb device" at all) was due ti the installation of a hacked version of drivers for my usb3 and sata 6 controller PCI Card (asus u3s6).
    I found that out when in my clean install of mountain lion i installed the hacked kext files of the driver for the asus card.

    I am confirming that doing an installation of mountain lion 10.8.1 on the already installed system (on your hdd with the already installed mountain lion) solved the problem (propably because of overwriting the kext files on the system/library/extensions.

    I prefered the "installation" instead of just copying the original kext files to the system to avoid possibly permission problems in the folder and the possibility to not be able to boot at all in my mac (because of that)

    So the conclusion is that the camera still don't need any external driver installation at all. It works with the default general drivers as in snow leopard and in lion and maybe in some cases you should do the "midi trick" (with "audio midi setup.app") to make it work, after every restart (as before mountain lion).
     

Share This Page