Logitech X-540 5.1 Speakers.

Discussion in 'Mac Basics and Help' started by Gamble, Jun 23, 2009.

  1. Gamble macrumors member

    Joined:
    Apr 3, 2008
    #1
    I did myself a search and found a few threads on what im after and there were a few things that helped but i was after something more in my language :p

    So im planning on buying these. I have the iMac before the one that is currently being stocked so the 2.4ghz Dual Core.

    Just wondering if i purchased these speakers if i am to require any other hardware as well?

    I intend to use these for Music/Gaming/Movies so the lot really so if there is anything else out there for the same but better please let me know :D

    Any help is greatly appreciated!
     
  2. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #2
    I don't believe the Logitech speakers you refer to have an optical in (TOSLINK) connection. Therefore you would need an external sound card like the now discontinued Griffin Firewave. It is Firewire 400 so if you are using other than the latest iMac (you said the generation before) you will be fine. If it is the newest iMac with Firewire 800 only you will also need a Firewire 800->400 adapter.
     
  3. Gamble thread starter macrumors member

    Joined:
    Apr 3, 2008
    #3
    Thanks for the info!

    My item has been dispatched now so ill take a look at it myself when it turns up. I will probably understand it a bit more when i have got it here in me hands :D
     
  4. Gamble thread starter macrumors member

    Joined:
    Apr 3, 2008
    #4
    Finallly got this all delivered and sorted, got everything hooked up and all the speakers are crackly >.<

    Are fine but when i get a higher note or higher bit of bass they just start crackling, they were fine before the firewave but with the firewave plugged in they crackle :(

    Any ideas? :)
     
  5. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #5
    I saw a post where someone who was reporting crackling issues with the Firewave turned out to have a bad Firewire cable. Do you have another one you could try for a test?
     

Share This Page