London Underground Wifi Issue

Discussion in 'iOS 7' started by MBPMax, Nov 28, 2013.

  1. MBPMax macrumors member

    Joined:
    Jun 10, 2010
    Location:
    Germany & UK
    #1
    Hi!

    Last summer Virgin Media started providing Wifi in most tube stations here in London and my iPhone managed to connect automatically just fine every single time. That is, it would display the Wifi symbol as soon as I unlocked the phone. Now ever since upgrading to iOS 7 it stopped connecting automatically and I have to do something that requires Internet - like go on Facebook or Spotify - for it to connect. And even then I get this annoying pop up that prompts me to click continue before I am actually connected to Wifi.

    I made sure auto-connect and auto-join are enabled, but even that doesn't seem to change anything.

    I realize this is very UK/London-specific, but maybe the one or other Londoner can share their experience or perhaps this phenomenon is known. My carrier is O2, if that helps at all.
     
  2. Ubuntu macrumors 68000

    Ubuntu

    Joined:
    Jul 3, 2005
    Location:
    UK/US
    #2
    It's worked okay for me. Have you tried forgetting the network and adding it again?
     
  3. MBPMax thread starter macrumors member

    Joined:
    Jun 10, 2010
    Location:
    Germany & UK
    #3
    I think I've done that. But I'll give it another try tomorrow - thank you!
     
  4. davehutch macrumors 6502a

    davehutch

    Joined:
    Mar 5, 2009
    Location:
    Croxley, Herts
    #4
    Mine used to behave as yours does, but since September, it now just pops up an automatic log-in screen that just requires me to press "Done"
     
  5. LV426 macrumors 6502a

    Joined:
    Jan 22, 2013
    #5
    Many public WiFi providers require the user to interact with a web page before any kind of internet traffic can flow once you're in WiFi range. I'm guessing you had to do this on at least one occasion with Virgin, if for nothing other than to accept their terms and conditions, and possibly to provide them with some personal details. Having done that, Virgin most likely put a cookie on your device that identifies you. They will have also recorded your browser's user agent string. A subsequent upgrade to iOS7 would send a different user agent string to Virgin. It's really down to them how they handle a situation like that, and their internal systems could get up to all kinds of tricks.

    You certainly can't be sure that just because a WiFi icon appears, you are connected to all your favourite internet services like e-mail etc. (unless you're connected to a proper router that authenticates silently, like the one you've got at home). When the ISP is waiting for you to interact via a web page, other services can be oblivious that there's a block, and will just patiently wait until data flows. Sometimes you'll get the ISP's popup page; other times you won't.

    Since cookies are not transmitted back to the ISP unless you are viewing a website, it would actually be pretty obliging of Virgin to let you connect to services such as e-mail without opening a web page. They probably also have a legal obligation to identify you, so that they can record your online behaviour.
     
  6. WillFisher macrumors 6502

    WillFisher

    Joined:
    Feb 19, 2011
    #6
    I'm the same as davehutch, since coming back to uni in September I have to "login" initially at the station, click done, then it works fine.

    I have noticed the connection isn't as stable as it was, don't know if thats iOS7 or just a large number of people now on the Underground Wifi though.
     
  7. MBPMax thread starter macrumors member

    Joined:
    Jun 10, 2010
    Location:
    Germany & UK
    #7
    Thanks for the input, guys! I 'forgot' the network and logged in again, and now the behavior has started to become quite random. I still get the pop up whenever I enter the station and do something requiring internet, but as soon as my train rolls into the next station, wifi automatically reconnects (i.e. wifi symbol is back) without me having to do anything. Unfortunately this is quite inconsistent and on some occasions the pop up returns. I have a suspicion this depends on the station, though I'd have to keep a little better track of this to be completely certain.

    I can live with it and am happy there's free Wifi at all, though I feel that pop up serves no purpose as it displays no ad and does not even require me to click anything.
     
  8. The Phazer macrumors 68030

    Joined:
    Oct 31, 2007
    Location:
    London, UK
    #8
    I've had the same issue - the reconnection handshake so the phone will load the redirect page to click through isn't anywhere near as quick in iOS7 as it was in iOS6.

    And when you've got 15 - 20 seconds in a station to try and load something that's actually kind of a pain.

    But I don't know if it's just that the tube wifi's configuration just isn't very good, and it's something that is in Virgin's gift to fix.
     

Share This Page