Long delay after clicking on links

Discussion in 'Mac Apps and Mac App Store' started by badlydrawnboy, Mar 6, 2010.

  1. badlydrawnboy macrumors 65816

    Joined:
    Oct 20, 2003
    #1
    About three days ago I started having a strange latency problem with my internet connection. When I click on a link, it takes a long time to load and sometimes doesn't load at all. If I click on the "stop" button and then "reload", it loads very quickly. This doesn't happen every time I click a link, or with every link I click, but it's happening often enough that it's seriously slowing down my browsing.

    I'm on a Mac Pro connected via ethernet to a Comcast high speed cable connection. The cable modem is also connected to a D-Link router with a wireless network, which we use for the three other computers in the house. Here's the strange thing: the other three computers aren't having the same latency problem. It's just my Mac Pro connected directly to the network that's having the problem.

    Any ideas where to start looking?
     
  2. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #2
    Compare the DNS settings. It's possible that your Mac is hard-coded to primarily point to a server that is no longer active, in which case you'll need to change it to match the settings on the other computers.
     
  3. badlydrawnboy thread starter macrumors 65816

    Joined:
    Oct 20, 2003
    #3
    The other computers are Macs. The main difference is that my desktop is connected to the net via Ethernet, whereas theirs are connected via Airport. I guess I could just try connecting via Airport as well and see if that changes anything.
     
  4. badlydrawnboy thread starter macrumors 65816

    Joined:
    Oct 20, 2003
    #4
    I tried switching over to the Airport network, and am still having the problem. DNS settings are blank on all machines (i.e. set automatically?)
     
  5. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #5
    What's your free disk space figure? Also, when you open up Activity Monitor what is your CPU %idle figure?

    One more thing. Is IPv6 enabled in your networking preferences? If so, what happens when you turn it off?
     
  6. badlydrawnboy thread starter macrumors 65816

    Joined:
    Oct 20, 2003
    #6
    I have several internal disks, all have over 300 GB of free space. CPU usage is fine.

    I'll try turning IPv6 off. It's set to automatic now.
     

Share This Page