Long delay at boot before the apple logo - tried everything!

Discussion in 'MacBook Pro' started by guy86, May 21, 2018.

  1. guy86 macrumors newbie

    Joined:
    Oct 3, 2010
    #1
    I have this debilitating issue with my Macbook pro 2014 retina, it has this long delay before the apple logo shows up - somewhere between 40 to 60 seconds. I've tried all the usual tricks multiple times, NVRAM and CMS reset, permissions repair, reinstalled a fresh OS X Yosemite twice. The machine is running on an apple 128gb SSD.

    So, new freshly installed system, very first boot, apple logo appears almost instantly. No problem. As I open a few windows, particularly the 'startup disk' in the preference panes (but not doing anything else but clicking on it), the long delay appears at the next startup. I run 'permission repair' on the drive and at this very early stage, it might fix it but only momentarily. However, without exception, once I plug any peripherals in - usb drives, memory cards etc., the fault is back. And I don't mean leaving it plugged in through the startup, only connecting it just to copy a few files.

    Then, after a few startups, nothing will fix the delay anymore. It's almost as if the machine is extremely sensitive to connecting of new drives, bootable or not, even if only momentarily, and throws the boot sequence out.

    Other glitches I have observed are also related to boot. I make an Yosemite installer with Diskmaker X and it shows on the startup disks pane, but will NOT show up at startup boot manager with the option key pressed. If I make same installer through terminal, situation is reversed: it will NOT show up in startup disks but will appear in boot manager.

    These symptoms might not make much sense but there's definitely a root cause of all this, and I think it's fair to say the process by which the machine recognises eligible boot drives is partially corrupt. In fairness, it always boots in the end but seems to be terribly hesitating. I would also assume it's something that resides outside of the operating system, because multiple fresh installs didn't fix the issue, and after the logo appears everything boots lightning fast.

    Sorry for the novel, I'm out of ideas at this point, and any advice would be greatly appreciated.

    P.S. Checked to console log, there is no activity whatsoever recorded within those 40-60 seconds. Did the hardware test, came up with 'Potential display problem' (code VFD002). I'm reluctant to think this is related.
     
  2. Audit13 macrumors 68040

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #2
    Try a newer os? Installing Sierra out high Sierra will update the machine's bootrom.
     
  3. keysofanxiety macrumors G3

    keysofanxiety

    Joined:
    Nov 23, 2011
    #3
    PRAM reset almost always fixes the long white display issue. However it's important to note that the white display before the Apple logo is doing a quick hardware check - you may have noticed on older models that it would spin up the DVD drive briefly and make a weird robot noise in the process.

    As such if the hardware test is showing a potential display problem and it's hanging on the hardware check, I'd say that's almost certainly the cause.

    Again just a quick reminder: hold CMD + ALT + P + R on startup, wait for Apple boot chime 3 times, then let go. I know you've already done it a few times but it can't hurt to try once more. If this still doesn't work, I'd say it's almost definitely to do with that error code.

    However, can't hurt to try the usual stuff. Update to the latest OS, if you're still having the issue, then do a CMD + R wipe/reinstall of that latest OS through the recovery partition.
     
  4. guy86 thread starter macrumors newbie

    Joined:
    Oct 3, 2010
    #4
    Thanks guys, I will upgrade the OS but only as a last resort. I'd rather live with it as is, if I can't find a fix for it.

    @keysofanxiety I did the PRAM multiple times and multiple chimes, I've exhausted that to death since it's all I had. It's interesting that you don't dismiss the display's 'potential' fault, you might be right but what throws me is this glitch seems to revolve around bootable/non bootable peripherals. I hope you're not right though, cause that's definitely a costly hardware problem - if not now, certainly down the line.
     
  5. treekram macrumors 68000

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #5
    In System Preferences -> Startup Disk, make sure the text "You have selected macOS, ..." appears below the gallery of startup disks. If it doesn't, you have to click on the startup disk you want until it does appear. If this doesn't work, you can try going into verbose mode and see if there's a helpful message.
    https://support.apple.com/en-us/HT201573

    You can also try going into the Startup Manager, which allows you to choose the startup disk. This could be helpful in isolating where the delay takes place - if it happens after the Startup Manager appears, then the computer is having some issue in loading the OS.
     
  6. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #6
    Did you go to the Startup Disk pref pane and designate the SSD to be the boot drive?

    If you boot with the option key held down, do you still get "a long startup delay"?
     
  7. guy86, May 22, 2018
    Last edited: May 22, 2018

    guy86 thread starter macrumors newbie

    Joined:
    Oct 3, 2010
    #7
    Yes, the SSD is indeed the designated drive in the Startup pane - and I mean selected, not just present. If I boot with the option key down, the delay is still there. The boot manager doesn't load up until after the delay.

    Anyway, I took the cover off to have a poke and discovered that if I disconnect the IO board, it boots immediately as expected. I am assuming there is a bad connection or even a short somewhere on that board. We'll find out soon enough, that part is the interface for the 2nd USB, HDMI port and SD card reader, so it kind of make sense. A bad connection to a peripheral can generate this sort of glitch. Picture with the board below.
     

    Attached Files:

  8. _Kiki_ macrumors 6502a

    Joined:
    Aug 13, 2017
    #8
    this part is pretty cheap, don't forget to replace cables
     
  9. guy86, May 24, 2018
    Last edited: May 24, 2018

    guy86 thread starter macrumors newbie

    Joined:
    Oct 3, 2010
    #9
    Good point about the cable, in this case the fault was indeed somewhere on that IO board. Replaced the board with a second-hand one, it was under £20 off eBay. All sorted now, thanks everybody :)
     

Share This Page