Longest Streak Achievement Award

Discussion in 'Apple Watch' started by Mlrollin91, Apr 8, 2016.

  1. Mlrollin91 macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #1
    Hello All.

    Right off the bat, want to let you know that I have already spent 5+ hours with Tier 2 support trying to figure out this issue. No one can find anything about the problem, let alone even try to remedy it. According to some developer bug posts, it was an issue with watchOS 2.2 Beta 1&2 but was solved in Beta 3 (theoretically).

    So to the meat of the post. 5 days ago, I randomly stopped received my medal for longest move streak. I have beat the move streak every single day, so its not that I missed it. But for whatever reason it is no longer be awarded. Now here is the kicker. If you Wait 1-2 days, unpair my watch and repair it to the backup that it just created, my activity app awards me the move streak medal on all the past days that I reached my move goal. But, the activity app will not give it to me for the day I complete the goals after restoring or any day going forward, until I do the restore method again.

    Has anyone seen any behavior like this? It is so bizarre. It is clearly keeping track of my streak because it will update it after the restore with the proper amount of days the streak actually is, but it won't automatically update on its own. I won't know until the end of the month if it has screwed up my perfect month, but this only started after updating to 2.2. I have already tried unpairing my watch and setting it up as new, I have restore my iPhone to an earlier backup, I have reset all settings on my phone and nothing.

    Sorry for the long pots.

    TL/DR:

    Watch no longer gives me longest streak medal even though I have completed move goal every day.
     
  2. Julien, Apr 9, 2016
    Last edited: Apr 9, 2016

    Julien macrumors G4

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #2
    Is it completing the ring and is all activities recorded in the Activity App? If so don't sweat (only figuratively, but keep it up literally :D) about a medal since it is just a repeated everyday occurrence anyway. As long as all data is recorded correctly you are good to go and not losing anything. If you are completing your goals then you don't need someone to give you the same 'gold star' every day to stay motivated. It is one of those odd anomalies that will probably 'fix' itself in time or in the next update.

    EDIT: Also does it show up in the daly History view?

    [​IMG]
     
  3. Mlrollin91 thread starter macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #3
    Yes. I'm completing everything fully. But the medal doesn't appear on its own. Not under the daily view or achievements tab. Only if I do a unpair/repair session 1-2 days after I completed the day. It's so bizarre. I know it's tracking it properly because when I do the restore the medal appears with the right amount of days. But it just won't do it on its own.

    Thanks for the reply though! It's bugging my OCD about completion, even though I know I did it.
     
  4. cbronfman macrumors 6502

    Joined:
    Feb 24, 2008
    Location:
    Washington DC
    #4
    --- Post Merged, Apr 11, 2016 ---
    First time today this weekend, I had a problem with achievement awards. Normally - like clockwork after I've completed something or the next morning at the latest - but this time - nothing. I did a full week of move goal, stand goal, exercise goal - I usually get 4 medals - 1 for a stand week, 1 for move week, 1 for exercise week and for a perfect week for all three. THIS week - nothing when they always are awarded Sunday or early Monday. Nothing yesterday or today.

    Now I have 2 Apple watches - and they both update I guess from my iPhone when I swap them out - and technically each is unpaired when the other is paired - but I changed last night before I went to bed, this morning before I went to the gym (I use the one with the silicone band for workouts (particularly a swim) and the nylon band one for the rest of things once the battery on the silicone band one gets below 20%). They've been updating fine although oddly since the last update, I find periodically my bluetooth or WiFi is turned off (which I haven't done). I'm not sure what is going on. I'm not going to worry about the appearance of the medals - although since I earned them I do want them.

    The silicone band one I've had for about 8-9 months and the nylon band one only a few weeks since Apple lowered the price and offered the new bands. But the awards came in fine for 2-3 weeks. and now not. The only one I"m getting is that I doubled my move goal - and randomly I think last Wednesday I got a gold star for workouts in a week. Since the data is there for you, I'll assume it is for me too. All the actual data is there and all the workouts and the daily history etc. I restarted the watch today - and the phone. NOPE no awards. If I did your approach, I'd have to unpair and repair 2 watches. WAY too much time and it was hard enough to do when I added the second watch a few weeks ago.
     
  5. Mlrollin91 thread starter macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #5
    It is extremely annoying and now it's getting weirder. Occasionally after 2-3 days now without restoring it will award the medals and then put the on past days too. Happened last night when I was awarded my 4 perfect weeks, the longest move streak was added for the past 3 days. But then again today after I beat my move goal, no award. Can't wait for 2.2.1. Hopefully it fixes this nonsense.
     
  6. cbronfman macrumors 6502

    Joined:
    Feb 24, 2008
    Location:
    Washington DC
    #6
    You give me hope ... maybe it's a known bug and they'll repair it??? Next update. I'll wait I guess having no other options.
    --- Post Merged, Apr 11, 2016 ---
    I just referenced the thread and gave Apple Feedback.
     
  7. Mlrollin91 thread starter macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #7
    According to bug logs. This was a bug in the first two betas of 2.2. It was fixed in beta 3. But could have been broken again in final.
     
  8. cbronfman macrumors 6502

    Joined:
    Feb 24, 2008
    Location:
    Washington DC
    #8
    --- Post Merged, Apr 11, 2016 ---
    Thanks. OK so it was identified, 'fixed' and ITS BACK. Where do you find the bug logs.
     
  9. Mlrollin91 thread starter macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #9
    Here is this specific one. But OpenRadar has bug reports for all software, i.e. OS X, iOS, watchOS and tvOS.
    http://www.openradar.me/24238493
     
  10. cbronfman macrumors 6502

    Joined:
    Feb 24, 2008
    Location:
    Washington DC
    #10
    All of my awards appeared this morning ,,,with the appropriate date - April 10th when they should have appeared. Very odd, but I'm not complaining (until the next time). Thanks for the link to bugs.
     
  11. Mlrollin91 thread starter macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #11
    I have no received my longest move streak in 3 days. Will probably get it today or tomorrow and have it all back dated again. This is definitely annoying. But at least it's keeping track.
     

Share This Page