Looking for OD only binding script / need help with binding to OD with DPS

Discussion in 'Mac OS X Server, Xserve, and Networking' started by dabizkitman, Jan 21, 2013.

  1. dabizkitman macrumors newbie

    Oct 16, 2012
    Hello everyone,
    after several weeks of trying different solutions we are stuck with trusted binding / OD binding in Deploy Studio.
    We've added several workstations to our computers and they are renamed by a script this works fine.
    The problem is that we have to add those workstations to our Open Directory and then add those workstations via OD to several groups.
    The workstation is binded but it doesn't bind correctly.
    We can see the OD server in the "Users and Groups" as "connected". But it's only bound locally (can only be seen on the workstation)
    But it's not binded as we want it to be.
    Our goal is that the workstation needs access to the directory (System Preferences -> Accounts -> Login Options -> Network Account Server -> Open Directory Access… --> LDAPv3 ...)
    And then we have to use "Edit..."-> "bind" .After that the workstation is added to our OD and we can see it in our workgroup manager and add this workstation to the group.
    Is it possible to solve this issue with Deploy Studio?
    We've already tried to use "Enable trusted binding" but after imaging a workstation there is only the ouput "An error occured while trying to establish a trusted binding with the server "xxxxx",new attempt in 10 seconds..." and "Invalid credentials supplied for binding to the server" in the finalize script and the workstation has to be bound to the OD manually.
    But the credentials are 100% correct.We are using the login of your OD-administrator account for the trusted binding.
    We've also tried to activate trusted binding without any login information in the fields for "Directory Admin", after that there is no error but the workstation has to be bound manually again.
    It would be great if there is anybody who has the same issue and maybe solved it or has any idea what to do here.

    Sorry if the english description for several "buttons" aren't exactly,we are using a german version of MAC OS X (10.8.2). I hope everything is easy to understand.
    Just tell me if you need any additional information about things.

    DPS Version: 1.0 RC 135 (121112)

    Kind regards


    This is my post in the official DPS forums but there wasn't any reply except one that we could use an own OD binding script.

    Is there anybody who has a working script?I found one but it has AD inside and I don't know if it's that easy to delete the AD parts from this script.

    It would be great if there is someone who could help with this issue.
  2. dabizkitman thread starter macrumors newbie

    Oct 16, 2012
    We haven't been able to find a solution for this issue,even with a newer version of DPS.
    Is there anybody who has an idea?
  3. DJLC macrumors 6502a


    Jul 17, 2005
    Mooresville, NC
    I'm not sure that I have a solution, aside from advising you to double-check your DS workflows and network infrastructure. I do see this error on maybe 10% of the Macs we image, but it always seems to resolve itself before the DS finalize script gives up.
  4. dabizkitman thread starter macrumors newbie

    Oct 16, 2012
    Thanks for your reply.
    Have you tried to bind a mac by using a script?
    I tried the following one but it brings up the same error,that my credentials are invalid:

    computerid=`scutil –get ComputerName`
    dsconfigldap -v -f -a OD_SERVER -n OD_SERVER -c $computerid -u ADMIN_USERNAME -p ‘ADMIN_PASSWORD’
    sleep 10
    dscl /Search -create / SearchPolicy CSPSearchPath
    dscl /Search -append / CSPSearchPath /LDAPv3/OD_SERVER
    sleep 10
    dscl /Search/Contacts -create / SearchPolicy CSPSearchPath
    dscl /Search/Contacts -append / CSPSearchPath /LDAPv3/OD_SERVER

    OD_SERVER= FQDN of our OpenDirectoryServer
    ADMIN_USERNAME= account used for binding computers manually
  5. atperseghin, Jan 8, 2014
    Last edited: Jan 8, 2014

    atperseghin macrumors newbie

    Jan 8, 2014
    I was having a similar issue with a join to AD script I was writing. On 10.7 I was able to run the script with no issues. I tried to run it on 10.8 and 10.9 and it would say "your credentials are invalid". After some research I found that I needed to run the script as root. I made this easier by writing another script that runs the AD script as root.

    Not sure if it will help, but try running the script as root.

    For Reference

    Join to AD script

    echo “Enter Computer Name:”
    read computername

    echo The Computer Name is $computername

    scutil --set ComputerName $computername
    scutil --set LocalHostName $computername

    dsconfigad -add your.domain.com -username domainaddminaccount [-computerid $computername] [-ou CN=Computers,DC=your,DC=domain,DC=com] [-mobile enable] [-mobileconfirm disable] [-useuncpath disable] [-shell /bin/bash]

    Run as Root Script

    sudo /Path/To/Your/Script/JoinAD.sh
  6. HackBook, Jan 9, 2014
    Last edited: Jan 10, 2014

    HackBook macrumors member

    Nov 24, 2007
    Essex, UK
    I've probably got the wrong end of the stick, but I had a similar issue whereby the Macs in our network do not show up in OD properly unless they are assigned to an OD group when they are imaged in DeployStudio. (Running OD & AD in the Magic Triangle config, Mountain Lion 10.8.5 server). In order to combat this, I specify the groups from the Hostname form in Deploy Studio. In the Client Management box, type the OD group you want the machine to be a member of, then press Enter. Repeat this process for each group you need to join. Also, if you are using DeployStudio to join to OD, then make sure you tick the "Apply computer's Client Management settings automatically" tick box in the OD bind area of the workflow, otherwise it won't apply the memberships.

    I have attached screen grabs of these boxes in case you are unfamiliar with them.

    Hope that this is of some use!

    Attached Files:

    • S1.png
      File size:
      91.3 KB
    • S2.png
      File size:
      133.5 KB

Share This Page