Looking for theories on pathetic Lightroom 5.5 performance on nMP

Discussion in 'Mac Pro' started by hualon, Jun 24, 2014.

  1. hualon macrumors 6502

    Joined:
    Feb 5, 2008
    #1
    I have a brand new Mac Pro 6,1 (6-cores, 32GB RAM, D500) and I'm having irritating problems with Lightroom 5.5 (CC).

    Internal Storage
    Lightroom Library (approx. 90-110k images) file
    Lightroom Previews file
    Lightroom Smart Previews file

    USB 3 Storage (7200RPM 3TB)
    RAW files (CR2, DNG mix)

    I have found that the adjustment brush is not very responsive. I will paint on adjustments showing the red mask overlay and see this blocking as I brush like the computer is really struggling to keep up with my strokes.

    Once I'm satisfied (at last) with adjustments I'll copy the adjustments, switch to the Library module, and then paste the changes to 200 or so similar images. This is where things get really irritating.

    Once the adjustments are pasted I'll double click an image at random to confirm that everything looks the way I want it to. Lightroom takes up to twenty seconds to render the image in the Develop module.

    I went back to the Library module, selected the mass of images, and instructed Lightroom to render 1:1 previews. These previews take 20-30 seconds to render per image.

    I'm working with RAW files from a Canon 6D (22MP ~ 25MB each).

    WHAT is going on here? I'm not sure what I can do to make things snappier. Smaller library? I can see that the processors are in use to the tune of about 500% during the render process and LR is using only a few GB of RAM.
     
  2. shaunp macrumors 65816

    Joined:
    Nov 5, 2010
    #2
    Have you tried storing your images on the internal SSD? If this performs okay then the USB3 drive is the issue. I've got a similar configuration (6 core, D700's, 64GB RAM, 512GB SSD) but I store my photo's on a Pegasus 2 R4 thunderbolt array.

    In theory the image should all loaded into memory - 32GB is ample - so I can't see why it would be slow. I can only think that if it is editing direct from disk then USB 3 could be an issue?

    ----Edit

    I've just tried creating the 1:1 previews and they take around 2 seconds each. These are 15MP RAW files from a 50D.
     
  3. hualon thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #3
    Approximately how large is your library?

    I can try moving a bunch of files over to the internal storage to test but I have almost 3TB of images so that's not going to be a long-term solution. I'm looking into that Pegasus2 R4 array now. What drives do you have installed in it?
     
  4. shaunp macrumors 65816

    Joined:
    Nov 5, 2010
    #4
    Hi my library is approximately 24,000 images - 286GB. The catalogue is 16GB.
     
  5. hualon, Jun 25, 2014
    Last edited: Jun 25, 2014

    hualon thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #5
    This morning I moved about 250 files from the USB3 drive to internal flash. The transfer was really fast!

    I ran the generate 1:1 previews command again and still they took 15-20 seconds to render.

    Even in Library mode just moving between the files one by one with the arrow keys it took almost five seconds for the image to resolve from a blurry mess into something that I could usefully review.

    I'm going to run a catalog optimize routine tonight and then generate 1:1 previews on everything before I go to sleep. Maybe once I have full previews on everything the speed will increase. Overall, however, I'm really disappointed in the speed of Lightroom on any computer regardless of specs.
     

Share This Page