Loops disabled/unable to download in Garageband

Discussion in 'Mac Apps and Mac App Store' started by Brian Mage, Aug 12, 2012.

  1. Brian Mage macrumors member

    Joined:
    Jul 14, 2012
    #1
    Hello.
    I'm unable to download the "additional content" for garage band form the app store.
    When in GB, i want to use some loops however they are grayed out. When i click them I am prompted to download. I click OK
    [​IMG]

    However, i am then directed to the app store, but no updates are available.
    [​IMG]

    When i go back to GB, the files are still missing, but they are stated as being downloaded. [​IMG]

    The problem is that they don't download. I check the data coming into my MBA and the web content is next to zero. Tried this process for a few days, and nothing. I've googled this matter and all the answers seem to be -reinstall. however i have an MBA and therefore no iLife disk

    Please help if you can
     
  2. Brian Mage thread starter macrumors member

    Joined:
    Jul 14, 2012
    #2
    Not meaning to bump. Apologies if i annoy anyone

    Does no one have any experience of this?

    Having done a LOT more research on 't'interweb it seems it might be something to do with the actual installation on GB at point on manufacture. Apple seem to think that i would only ever want to update this App online and therefore i can't manually download the updates/patches or use a DVD via a USB Optical drive...

    Frustrating much!
     
  3. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #3
    Since Apple switched GarageBand over to the App Store, the update mechanisms used in the past have been disabled, due to the certificates that make them work expiring. Unfortunately, this makes it extremely difficult to do what you're trying to do, if it's possible at all.
     
  4. Brian Mage thread starter macrumors member

    Joined:
    Jul 14, 2012
    #4
    Thanks for the reply.

    While it wasn't the answer i was hoping for, it is greatly appreciated.
    [trudges off to Apple Store to shout Fix this!]
     
  5. freiheit macrumors 6502a

    Joined:
    Jul 20, 2004
    Location:
    California
    #5
    Only loops purchased through App store?!

    So, wait. Are you saying that if you get GarageBand pre-installed now or buy it through the App store, it doesn't allow you to add loops you might already have on DVDs or downloaded from other sources? You can only use loops purchased through the App store?
     
  6. dkl macrumors member

    Joined:
    Aug 4, 2012
    #6
    I'm having the exact same problem with Garageband! Thanks for the snapsnots - they make describing the issue so much clearer!

    Now, I'm still looking for a solution to this.... anyone? =(
     
  7. scooterguitar macrumors regular

    Joined:
    Mar 7, 2008
    #7
    Bring this TTT...
    Same thing here, any workarounds yet? How about a direct installer from Apple's site perhaps?

    I started completely fresh after getting my iMac back from repair. Forgot to update loops on 10.6.8 and went ahead and installed Mountain Lion, now I can't download loops for GB '09.
    I'd prefer to wait to get a newer version of GB, which I assume will be updated this summer.

    I do have all the loops on a different Mac, is there a way to copy those and install in my ML version mac?
     
  8. scooterguitar macrumors regular

    Joined:
    Mar 7, 2008
    #8
    Ok, spoke with applecare.
    Apparently when the apple repair shop reinstalled or whatnot the software, the must have imaged it with GB'11, which I never had. Oddly, none of the features of '11 are shown (flex time, various amp models, etc). They said '09 will not work with Mountain Lion, so if I try install my old '09 iLife suite it won't work.
    So, am I to assume I have to uninstall whatever GB it actually is on my iMac and then purchase GB '11?
    Ugh.
     
  9. d1stewart macrumors newbie

    Joined:
    Jun 29, 2013
    #9
    I have GarageBand '11, and am experiencing the exact same issue. It is not the version of GarageBand that causes the problem. AppleCare didn't give you an accurate answer.
     
  10. firedept macrumors 603

    firedept

    Joined:
    Jul 8, 2011
    Location:
    Somewhere!
    #10
    I don't normally use GarageBand. On occasion when I want to make a new ringtone for my iPhone is about all I use it for. But just tried using the loops and got the initial request everyone has received to update the complete set. Clicked OK and it took me to the App Store and downloaded the update with no problems. I am using a late 2012 iMac 3.4 i7 24GB RAM with fusion drive and am currently up to date on everything. Below are posted screen shots of everything I did and it updated fine. Not sure why you are having problems or I do not have a solution as it worked just fine for me. I have tested it to see that it is all downloaded and available for using.
     

    Attached Files:

  11. d1stewart macrumors newbie

    Joined:
    Jun 29, 2013
    #11
    A solution

    The missing loops do belong in GarageBand '11, and have to be downloaded from Apple and installed into GB. The problem is, GB is broken in this respect, and it will not download the loops, and the App Store will also not update the loops. GarageBand will say it is downloading them in Software Update, but it will not do so.

    I called AppleCare about this, and it took a couple tries, but we got it solved. It's complicated to do so.

    It is, the support person said, the one thing broken in GB '11. Anyway, here's the procedure that worked to get them to install. (Hope I'm not giving up any state secrets here; they didn't swear me to secrecy and others do have the problem.)

    ---------------

    First thing to do is go to GarageBand and make it go through its fakeout cycle telling you it's updating the loops. Click on any gray loop's download arrow, and tell it to download it now. It'll open App Store, and that won't download anything, and it'll all fail. Quit App Store and GarageBand.

    Next, you need an administrator login user. I created one, called "apple" -- do this in the Users & Groups panel in System Preferences. (You do need admin privileges to do this; you may already have them in your own login, and thus not need to create an administrator login.) Gave it an easy password. Then, with Fast User Switching, I logged in as the administrator "apple."

    It'll take a few minutes for your machine to set up this new user, so be patient until it's all logged in. (The mouse will be slow. You can change that in System Preferences Mouse panel if you want to.)

    Now, open a Terminal window. Fastest way to do this: Spotlight (Cmd-Space), type in "terminal" and hit Return key once Terminal is highlighted in the Spotlight list.

    Let Terminal get all set up, with a cursor available.

    You'll see something very like:

    Last login: Sat Jun 29 18:55:22 on console
    ComputerName:~ apple$


    At the cursor prompt, type:

    sudo softwareupdate --list

    Hit Return. Now you'll see:

    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.

    To proceed, enter your password, or type Ctrl-C to abort.
    Password:


    Type in the password you created, and hit Return. Now you should see:

    Software Update Tool
    Copyright 2002-2010 Apple

    Software Update found the following new or updated software:
    * GBExtraContent-1.0
    GarageBand Instruments and Apple Loops (1.0), 1170290K [recommended]


    Select and then copy (cmd-C) the GBExtraContent-1.0

    Now, type at the ComputerName:~ apple$ prompt:

    sudo softwareupdate --install GBExtraContent-1.0

    Now, you'll see the update take place. It'll look like this:

    Software Update Tool
    Copyright 2002-2010 Apple

    Downloading GarageBand Instruments and Apple Loops
    104 KB of 1.2 GB
    1 MB of 1.2 GB — About 14 minutes
    2.5 MB of 1.2 GB — About 10 minutes
    4.1 MB of 1.2 GB — About 8 minutes
    6.1 MB of 1.2 GB — About 7 minutes

    [This will continue until it's all downloaded.]


    What you're seeing in that counting of GB and minutes is the countdown of the download and the install time. Let it run until it completes.

    Give it a couple minutes to complete installing, and then start GarageBand in the admin login. It will take some time for GB to start up, because it's the first startup for this user. Several minutes.

    Once it has completed (it takes a while, as I said), go to the Loop Browser. They should all be there, no gray.

    Quit GB and go to your normal User and start GB there. The loops should all be present. If not, quit it and restart it. Now they should all be there.

    At least, this worked for me this way.
     
  12. Marklar9797 macrumors newbie

    Joined:
    Jul 27, 2013
    #12

Share This Page