Loose volume switch on 3G?

Discussion in 'iPhone' started by jsamuelson, Oct 8, 2008.

  1. jsamuelson macrumors member

    jsamuelson

    Joined:
    Sep 12, 2008
    Location:
    Switzerland
    #1
    All of a sudden, my volume rocker switch on the side of my 3G is loose - there is play in it, and it wiggles up and down in the slot.

    Functionally it is OK, as in it still controls the volume fine.

    Does anyone know if it is glued on or screwed in - ie has it come adrift internally? I have hardly used the button, the default set ringer volume and headset volume are usually fine.

    Phone has not ben dropped, knocked or otherwise abused.

    I have checked 4 other iPhones and the volume switch on all of them is solid with absolutely no play.

    Does anyone else have a wobbly volume button? Am I being OCD or should I try and get a replacement phone now before the button falls off?

    Cheers, John
     
  2. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #2
    It's probably nothing, but at the same time it doesn't hurt to bring it in and see if they will replace it. Most button issues are coming from the silent switch, which is prone to falling off.

    The volume rocker switch probably isn't fastened to the casing in any way. Like most buttons, it's probably held in place by the pressure of a plastic, rubber or metal snap dome underneath, that keeps the buttons constantly pressed outward against the casing.
     
  3. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #3
    +1 ^^^ yup, take it in and get it replaced. Make sure you do a back-up and make sure you sync everything over like pics, music, videos, apps, podcasts, etc.
     
  4. jsamuelson thread starter macrumors member

    jsamuelson

    Joined:
    Sep 12, 2008
    Location:
    Switzerland
    #4
    Thanks guys, nice to know other people think this might be a problem!

    And on top of that, my screen went totally unresponsive today. Phone was working underneath this blackout, but no response from hardware buttons or touch. I plugged it into iTunes on my MBP, and it showed up as normal, and the screen flashed up briefly but not quick enough for me to slide to unlock it.

    It took two attempts at a reset before it came up.

    Software bug or hardware fault I really don't care. With the volume switch thing and a light leak too it's going back and I have told Swisscom upfront that a repair isn't acceptable, I want a brand new iPhone.
     

Share This Page