Losing Cell Data Connection Coming Off Wifi

Discussion in 'iPhone Tips, Help and Troubleshooting' started by rayward, Aug 27, 2012.

  1. rayward macrumors 68000

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #1
    This has been happening for a while. My iPhone will work fine on 4G, then on Wifi but, when returning to 4G, more often than not it will lose data connection. Phone/text works just fine, just not data.

    I called AT&T the first couple of times it happened, and they said that I had dropped off the network and had to reset. This is done through Settings, and the cell data service comes back every time, but it's a real pain having to do this a few times a day. Turning Wifi off is not a permanent solution, as an extended period of non-use will drop the data connection too.

    As an aside, my phone will also "forget" how to access my gmail account even though data is working for all other email accounts and apps. To fix this, I have to cycle the phone off and on. This problem started occurring at the same time as the data service drop.

    To fix it, I wanted to do a clean install of iOS. When I started this process, I was warned that I'd lose all my paid media/apps. Is this correct? I have the phone backed up to my Mac, so I was hoping to be able to reload all my media and apps from that. I (obviously) don't want to restore from backup, because I'll just be reinstalling the problematic setup.

    Any thoughts/ideas on the paid media issue, or the problem itself, would be appreciated.
     
  2. rayward thread starter macrumors 68000

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #2
    This was a problem under iOS5. Just wanted to update everyone as to it still being a problem after installation of iOS6.

    Awesome. :/
     

Share This Page