Losing Disk Space For No Reason!

Discussion in 'MacBook Pro' started by MacConvert2007, Mar 8, 2010.

  1. MacConvert2007 macrumors member

    Joined:
    May 23, 2007
    #1
    I have a 2009 MacBook Pro running Leopard with a 500 GB drive.

    I seem to be losing hard disk space for no reason while web surfing in about 500 MB chunks. I tried emptying the trash, clearing the safari cache and history, and all that returned was about 200 MB.

    Since I noticed this a week ago I've been keeping track, and have lost 4.5 GB of space for no reason.

    I'm not adding files nor running time machine or some other backup that's constantly creating a disk image.

    What should I do?
     
  2. MacDawg macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #2
  3. Freyqq macrumors 68040

    Joined:
    Dec 13, 2004
    #3
    Try running onyx. It could be cache or something similar.
     
  4. Bennieboy© macrumors 65816

    Bennieboy©

    Joined:
    Jan 15, 2009
    Location:
    england
    #4
    check your logs folder in the library, could be they need cleaning out ;)
     
  5. iThinkergoiMac macrumors 68030

    Joined:
    Jan 20, 2010
    Location:
    Terra
    #5
    Have you tried restarting? Very likely, a good amount of that space is being used by the swap file. Restarting will clear the swap file... if you want to see how big the swap file is, look under System Memory in Activity Monitor.

    Also, I'm a fan of DaisyDisk for seeing what space is used where (though it's paid, unlike the other two mentioned earlier). I've found it to be much, much faster than GrandPerspective or OmniDiskSweeper. OmniDiskSweeper gets confused by TimeMachine backups. I once had it tell me I had over 1 TB of information on my 250 GB external TM drive.
     
  6. kresh macrumors 6502a

    kresh

    #6
    You said you emptied the Safari cache, but did you clear the webpage preview cache at:

    ~/library/Caches/com.apple.Safari/Webpage Previews/

    That thing gets huge if you visit lots of websites daily.
     
  7. BornAgainMac macrumors 603

    BornAgainMac

    Joined:
    Feb 4, 2004
    Location:
    Florida Resident
  8. MacConvert2007 thread starter macrumors member

    Joined:
    May 23, 2007
    #8
    OK, I ran OmniSweeper on my hard disk. It showed 113.3 GB being used by my Library which seemed a bit high. Inside it 104.9 was in Application Support, and 99.4 GB of that for TechTool Protection.

    I know I have TechTool Pro 5 in my Applications, but I didn't think it was running all the time. Do I need to disable it from doing backups you think? Backups to the disk you are backing up seem a bit useless.
     

Share This Page