Losing Mail Because Of Spinning Ball/connection

Discussion in 'iPhone' started by insocal, Aug 29, 2008.

  1. insocal macrumors regular

    Joined:
    Jul 31, 2007
    #1
    Do you ever have to turn off/turn back on your iPhone because the Message you are trying to send won't send? It says CONNECTING but it never gives a Status Bar for the message being SENT. And then when you turn it off and then back on, it will connect but the message you had typed is gone? Not sent but gone.

    Is this a bug?

    It doesn't only happen from MAC mail either. It happens when sending from my Gmail accounts also.

    Is there a way to reset things but have the message not be lost? I tried putting the iPhone into Airplane Mode thinking I'd get a message that MAIL COULD NOT CONNECT but it still kept trying and only gave me a message saying if I wanted to use data, I had to turn on Wifi in Settings.

    This is happening A LOT.
     
  2. chanatown macrumors member

    Joined:
    Aug 17, 2008
    #2
    I had this happen to me once and I have decided to be more patient with the spinning circle since. Usually, it will end up sending the email if I wait or come back in later, but if I hold the home for 8 seconds while it is sending the email, it will definitely lose it. I imagine this is like hard resetting or force closing a program - you're going to lose the new data (in this case, the email). There are still some bugs with the mail/internet connectivity with the 3G. I thought some of these were fixed with the firmware updates, but it still needs work.
     

Share This Page