Losing my Mind: Spotlight/Menubar crashes

Discussion in 'Mac OS X Lion (10.7)' started by Nevermake, Oct 21, 2011.

  1. Nevermake macrumors member

    Joined:
    Feb 24, 2011
    #1
    Hey everyone

    Ever since I updated to 10.7.2, I've been getting some weird issues with Lion. The menu bar, top right, where all the icons for Battery, Spotlight, TM and so on are, crashes all the time (like literally every 30 seconds), and then reappears. Spotlight is non-functional, i can click on the magnifying glass icon, type one letter, and it will crash again.

    Did anyone else come across this problem?
    Can I fix it?
    ...or do I have to reinstall OSX?

    Thanks for any help, it's really starting to p*** me off... :/
     
  2. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #2
    Try downloading the Combo update and installing again.
    http://support.apple.com/kb/DL1459

    -Kevin
     
  3. Darby67 macrumors 6502

    Joined:
    Jul 5, 2011
    Location:
    the corner of Fire and Brimstone
    #3
    Do you have any 3rd party software installed? Sounds like a conflict. Have you checked any logs in Console?
     
  4. A.Chakery macrumors member

    Joined:
    Aug 27, 2011
    Location:
    Vienna, Austria
    #4
    Hi,

    I have the same problem in 10.7.1 ,

    Has this issue solved by manual update file ?

    thanks
     
  5. rkaufmann87 macrumors 68000

    rkaufmann87

    Joined:
    Dec 17, 2009
    Location:
    Folsom, CA
    #5
    +1 with KDMB, re-download and install the 10.7.2 combo update, sounds like a corrupt download or install.
     
  6. A.Chakery macrumors member

    Joined:
    Aug 27, 2011
    Location:
    Vienna, Austria
    #6
    I installed the latest update and it solved the problem,

    thanks everyone for the help.
     
  7. Nevermake thread starter macrumors member

    Joined:
    Feb 24, 2011
    #7
    I reinstalled the combo pack and wow, it worked for like 10 seconds!

    Unfortunately, after spotlight started indexing the problem reappeared. It seems, every time Spotlight starts to index, it starts crashing.

    Is it possible that there is an issue with my hard drive? I have a MacBook Pro 2011 with a OCZ Agility 3 SSD and the Factory 750GB HDD in the Optibay...

    According to Disk Utility, my drives are fine. But somehow I have a bad feeling about this, every time I open Disk Utility, I get Beachballs and lags...
     

Share This Page