Loss of Screen Sharing

Discussion in 'Mac OS X Server, Xserve, and Networking' started by dgbarar, Dec 15, 2015.

  1. dgbarar macrumors regular

    dgbarar

    Joined:
    Feb 27, 2014
    Location:
    Fountain Hills, AZ
    #1
    Hi All,

    I am operating OSX 10.11.2 on 2 MacBooks (rMBP and MBA) and on a late 2014 MacMini with OS X server installed. I use either of my MBA or rMBP to "control" the Mac Mini through Screen Sharing.

    I am always able to Screen Share with either of my MacBooks after I reboot. However, if for some reason i take one of the MacBooks offline for awhile or leave the network and come back to resume Screen Sharing to control the Mac Mini, I get an error message that tells me the Mini is not available.

    To restore the ability to screen share, I have to reboot the MacBook.

    Can anyone tell me how to resolve this problem as I would prefer not to have to re-boot.

    Sincerely,

    Donald Barar
     
  2. Hilbert92 macrumors member

    Hilbert92

    Joined:
    May 21, 2015
    Location:
    Ohio
    #2
    try checking the power settings and see if wake on LAN is turned on
     
  3. dgbarar thread starter macrumors regular

    dgbarar

    Joined:
    Feb 27, 2014
    Location:
    Fountain Hills, AZ
    #3
    Hi Hilbert,

    Tried that. Also, have the drives so they can not be put to sleep and so the display can not turn off event though there is monitor attached. Unfortunately, I still lose the ability to screen share.

    Don
     
  4. Eric M, Dec 18, 2015
    Last edited: Dec 18, 2015

    Eric M macrumors member

    Joined:
    Nov 18, 2009
    Location:
    UK
    #4
    This happens quite often in my enviroment as well. You can try two things that usually resolve this for me (on the Mac I'm connecting from):

    Step 1 --> Relaunch Finder - Command+Option+Escape, select Finder and press Relaunch - this usually does the job on its own, if it doesn't, try step 2...

    Step 2 --> Command+K and then in the " Server Address" type: VNC://<YOUR MAC NAME OR IP ADDRESS HERE> and Connect

    If you have SSH enabled on the Mac you're trying to connect to, you can also try restarting the VNC service:

    Step 3 --> SSH into the host and issue the following command:

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -restart -agent

    Then attempt Step 2 again.

    Some more info HERE
     
  5. dgbarar thread starter macrumors regular

    dgbarar

    Joined:
    Feb 27, 2014
    Location:
    Fountain Hills, AZ
    #5
    Hi Eric,

    Thank you for some terrific suggestions. I will give them a try.

    Donald Barar
     
  6. Eric M macrumors member

    Joined:
    Nov 18, 2009
    Location:
    UK
    #6
    No worries. Please let me know if any of the suggestions resolved your issue, if not, we can look at some other options...
     

Share This Page